PrimTux

La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

CARTE DES MEMBRES POUVANT AIDER ET DES ÉCOLES SOUS PRIMTUX
Merci de vous y inscrire en nous envoyant un email si vous souhaitez y apparaître.

Les différentes isos de PrimTux4 sont disponibles, cliquez ici pour choisir votre version.
  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 26-10-2016 00:16:39

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

désactiver le pavé numérique

Dans PrimTux2, le pavé numérique est activé par défaut.

Sur les PCs portables qui n'ont pas de pavé numérique, une dizaine de lettres sont transformées en chiffres.

Comment désactiver le pavé numérique pour ces PCs portables pour qu'il ne soit plus activé à chaque démarrage ?

Hors ligne

#2 26-10-2016 00:19:46

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

clavier => advanced => numlock state => off

ou

terminal => sudo numlockx off

Hors ligne

#3 26-10-2016 08:32:09

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Steph a écrit :

clavier => advanced => numlock state => off

ou

terminal => sudo numlockx off

Pour la première solution, graphique, le mot de passe administrateur ne suffit pas.
ou
le terminal est dans le menu accessoires, j'ai bien entré sudo numlockx off. La commande a été acceptée.
Au redémarrage du PC, le clavier numérique est à nouveau activé. Je n'ai pas trouvé dans le BIOS de paramètre qui active le clavier.
C'est un PC DELL. Je continue mes recherches.

Hors ligne

#4 26-10-2016 10:24:55

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Bon alors on va faire ça direct:
- Tu ouvres pcmanfm en root (outils => terminal => sudo pcmanfm)
- Tu te rends dans /etc/lightdm
- Tu ouvres lightdm.conf avec leafpad
- Tu commentes la ligne 122: greeter-setup-script=/usr/bin/numlockx on (commenter veut dire ajouter un # au début de la ligne)

Hors ligne

#5 26-10-2016 13:14:26

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

C'est fait, j'ai ajouté un # au début de la ligne greeter-setup-script=/usr/bin/numlockx on

Au redémarrage, le pavé numérique est bien désactivé (la petite lumière bleu sur la touche F4 du PC portable est éteinte).
Je peux entrer le mot de passe "tuxprof" pour me connecter à la session administrateur.

Cependant, une fois connecté en session administrateur, la touche bleu est à nouveau allumée.

La solution va être de désinstaller numlockx en passant par sinaptic, le gestionnaire de paquets.

Voilà, c'est fait, numlockx est désinstallé et la touche F4 ne s'allume plus au démarrage, à l'écran de connexion et une fois connecté à une session.

Pour les ordinateurs portables qui n'ont pas de pavé numérique, cela me semble la solution la plus simple et efficace.

Hors ligne

#6 26-10-2016 15:11:04

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Ok, merci chef big_smile

Hors ligne

#7 26-10-2016 21:58:38

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

J'ai trouvé dans le BIOS l'option pour que le "keypad" ne soit activé que par la touche "fn" de couleur bleu + la touche F4 (sur lequel est inscrit le chiffre 9).
= fn only
L'option activée était "Numlock". Il n'est donc pas obligatoire de désinstaller "Numlockx" si on trouve cette option.

Hors ligne

#8 27-10-2016 14:40:16

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 085

Re : désactiver le pavé numérique

C'est étrange, car j'ai installé PrimTux2 sur un portable ACER, et j'ai pas eu ce problème de clavier...

Où peut-être dire qu'il faut utiliser un clavier au moment de l'installation ! cool

Hors ligne

#9 27-10-2016 15:45:45

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Est-ce que le PC portable ACER dispose d'un pavé numérique ?
Sur le PC Dell, il faut appuyer sur "fn" et "F4" pour que dix lettres soient remplacées par des chiffres (de 0 à 9) écrit en bleu sur la touche des lettres.
Le BIOS était paramétré pour activer cette fonction par Numlock. J'ai changé en "fn" only.

Hors ligne

#10 28-10-2016 09:03:53

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 085

Re : désactiver le pavé numérique

ideefixe a écrit :

Est-ce que le PC portable ACER dispose d'un pavé numérique ?

Non.

Mais ce problème est peut-être spécifique à une marque ou à une série.

Hors ligne

#11 29-10-2016 11:32:45

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Après une installation fraîche de PrimTux2 sur ce DELL E5500, j'ai désinstallé Numlockx.
Mais je n'ai pas ajouté de # au début de la ligne greeter-setup-script=/usr/bin/numlockx on

Au redémarrage, cela empêche la procédure d'arriver sur l'écran de connexion pour choisir la session.

Hors ligne

#12 29-10-2016 11:41:20

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Après une installation fraîche, en session administrateur, terminal administrateur, sudo numlockx off
Dans le BIOS, j'ai activé l'option "fn = only"
Le LED de la touche F4 pour le pavé numérique est allumé, mais dans writer, les lettres ne sont pas remplacées par des chiffres.
C'est bien pour taper des lettres, mais je ne peux plus saisir de chiffres.
Si je remets sudo numlockx on, et désactive "fn = only", le pavé numérique s'active par défaut et il faut le désactiver  pour taper des lettres.
Je crois qu'il n'y a pas d'autre solution pour ce PC.

Hors ligne

#13 29-10-2016 12:14:48

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

je ai  ajouté de # au début de la ligne greeter-setup-script=/usr/bin/numlockx on

Le pavé numérique est bien désactivé sur l'écran de connexion et je peux entrer le mot de passe administrateur.
Dès que la session administrateur est ouverte, ou une autre, le pavé numérique est allumé et 9 lettres sont remplacées par des chiffres.

Hors ligne

#14 29-10-2016 12:15:46

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Non je ne crois pas que tu puisses faire autrement.

Hors ligne

#15 29-10-2016 16:48:30

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Bonne nouvelle :
Sous Emmabuntüs Debian Edition, après avoir effectué les mises à jour,
autologin activé, le pavé numérique n'est pas allumé à l'ouverture de session.
Dans LibreOffice Writer, les lettres sont bien des lettres, et en activant le pavé numérique avec "fn+F4", j'ai bien les chiffres écrit en bleu sur les touches des lettres.

Hors ligne

#16 29-10-2016 19:02:35

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Bonne nouvelle si on veut, il faudrait trouver pourquoi ça fonctionne sous cette distro et pas PrimTux, il y a tellement de manière d'activer ou pas le pavé numérique...

Hors ligne

#17 30-10-2016 11:39:22

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Avec PrimTux2-Lubuntu téléchargé sur sourceforge, installé à partir de la session Live, le pavé numérique n'est activé que à l'écran de connexion. Après avoir choisi une session élève, le LED s'éteint et il faut l'activer avec fn+F4 pour taper des chiffres.

Ces PC portables de 2010 supportent PrimTux-Lubuntu amd64. Ce sera la solution pour eux.

Hors ligne

#18 30-10-2016 11:42:01

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Je t'ai envoyé un paquet pour la Debian.

Hors ligne

#19 30-10-2016 12:31:09

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

J'ai installé le paquet pour PrimTux2 Debian. Sur ce PC Dell, cela n'a rien changé. L'institutrice m'en a confié six. C'est vraiment bizarre qu'avec Emmabuntüs Debian Edition, cela fonctionne et pas avec PrimTux2 Debian. Sous PrimTux-Eiffel, le pavé numérique ne fonctionnait pas du tout.

Hors ligne

#20 30-10-2016 12:45:31

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Ça doit tenir du choix que j'ai fait pour l'activer. Je n'aurais pas du inclure l'activation dans lightdm.
En même temps mettre des chiffres et des lettres sur les mêmes touche c'est pas fort malin...

Hors ligne

#21 30-10-2016 16:48:25

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Steph a écrit :

Ça doit tenir du choix que j'ai fait pour l'activer. Je n'aurais pas du inclure l'activation dans lightdm.

Voici en images comment désactiver le pavé numérique dans Lightdm.

Steph a écrit :

Pour les utilisateurs ayant un PC portable de type Dell Latitude e5500 avec la touche f4 allumée au démarrage et empêchant de taper correctement le mot de passe "tuxprof", qui devient "tux6r5f":

Ouvrir pcmanfm en root: outils => ouvrir le dossier actuel dans un terminal =>

sudo pcmanfm

Se rendre dans /etc/lightdm/
Ouvrir le fichier lightdm.conf avec leafpad
Ajouter au début de la ligne 122 (Options => cocher Numérotation des lignes dans leafpad): # de manière à ce que greeter-setup-script=/usr/bin/numlockx on devienne #greeter-setup-script=/usr/bin/numlockx on

Toujours en root, se rendre dans /etc/default/
Ouvrir le fichier numlockx avec leafpad
Remplacer NUMLOCK=auto par NUMLOCK=off

Hors ligne

#22 19-03-2019 16:06:02

ghis
Membre
Inscription : 04-03-2017
Messages : 166

Re : désactiver le pavé numérique

Merci pour ce tuto, très pratique, et fonctionne très bien avec PrimTux 4 (PrimTux4-Debian8-i686-2018-11-21.hybrid ) sur ordinateur Lenovo 3000 N200 qui présentaient le même problème (pas moyen d'entrer le mot de passe admin car le pad numérique sur les lettres était activé par défaut). Et zou 4 ordis portables de plus en cours de préparation pour une école primaire du Tarn grâce à vous et à ce tuto smile

Hors ligne

#23 19-03-2019 17:55:14

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 3 047

Re : désactiver le pavé numérique

Pourquoi installer PrimTux4-Debian8-i686 sur des ordinateurs dual-core avec 2 Go de RAM alors qu'ils pourraient supporter PrimTux4-Debian9-amd64-CTP ?

Dernière modification par ideefixe (19-03-2019 17:55:38)

Hors ligne

#24 19-03-2019 18:12:54

ghis
Membre
Inscription : 04-03-2017
Messages : 166

Re : désactiver le pavé numérique

Je me suis posé la question... Mais pour que ce soit plus simple, comme tous leurs autres ordis sont sous cette version, j'ai pensé (à tord ?) leur mettre cette version. Je perds du coup en performance, non ? De beaucoup à votre avis ? À part une perte en performance, est-ce qu'il y autres inconvénients ?

Hors ligne

#25 19-03-2019 18:29:01

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 636

Re : désactiver le pavé numérique

Non c'est juste une question de date de support rien de méchant.

Hors ligne

Pied de page des forums