PrimTux

La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

CONSULTER LES MENTIONS LÉGALES RGPD.

CARTE DES MEMBRES POUVANT AIDER ET DES ÉCOLES SOUS PRIMTUX
Merci de vous y inscrire en nous envoyant un email si vous souhaitez y apparaître.

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 30-11-2019 22:04:58

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

PrimTux4 pour Raspberry Pi 4ème génération

L'image de PrimTux4 RPi proposée en téléchargement, bâtie sur Raspbian Stretch, n'est pas compatible avec le nouveau Raspberry Pi, version 4. Il faut pour cela utiliser Raspbian Buster (Debian 10).

J'ai construit une PrimTux4 sur Raspbian Buster afin de la rendre compatible avec le RPi4. Cette image a besoin d'être testée avant d'en faire une diffusion publique.

Merci donc à ceux qui voudront bien la tester.

Pour ceux qui le souhaitent, il est également possible de la construire soi-même grâce à un script de construction. Voir ici : https://framagit.org/philippe-dpt35/primtux4-rpi4

L'image prête à l'emploi est téléchargeable ici : https://sourceforge.net/projects/primtu … z/download

Somme md5: https://sourceforge.net/projects/primtu … 5/download

Cette image nécessite l'utilisation d'une carte SD de 32 Go minimum.

Limitations de cette version :

Certains paquets ne s'installent pas, soit  parce qu'ils sont obsolètes, soit parce qu'ils ont des dépendances non satisfaites parce qu'elles sont manquantes. C'est le cas de leterrier-aller, openboard et solydxk-softwaremanager (gestionnaire de logiciels)

lsb-compat, qui permet l'installation de certains pilotes de scanners, n'est plus disponible.

Shutter n'est pas installable en raison d'une dépendance abandonnée dans Buster. Je l'ai remplacé par Flameshot.

Merci de faire vos retours dans ce fil de discussion, aussi bien sur le script que sur l'image prête à graver.

Cette version est utilisable sur les générations précédentes de Raspberry Pi.

Hors ligne

#2 30-11-2019 23:17:35

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 1 204

Re : PrimTux4 pour Raspberry Pi 4ème génération

Si je comprend bien, c'est la raspbian Stretch qui n'est pas compatible rpi4 ?
Si c'est bien ça, ça veux dire que je peux compiler sur une rpi3.

Je vais participer à l'effort de guerre en me concentrant sur openboard puis letterier-aller.

C'est dommage pour Shutter. Je ne sais pas ce que vaut Flameshot mais si je galère pas trop sur les 2 premiers, je regarderais également.

Hors ligne

#3 01-12-2019 00:06:44

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

mothsart a écrit :

Si je comprend bien, c'est la raspbian Stretch qui n'est pas compatible rpi4 ?
Si c'est bien ça, ça veux dire que je peux compiler sur une rpi3.

Oui, à condition de le faire sur une Raspbian Buster !

Hors ligne

#4 02-12-2019 12:01:59

chti5933
Modérateur
Lieu : WAVRIN Nord
Inscription : 31-10-2017
Messages : 374
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

mothsart a écrit :

C'est dommage pour Shutter. Je ne sais pas ce que vaut Flameshott.

Bonjour,

         je n'ai pas la compétence pour comprendre ce post, par contre je ne connaissait pas Flameshot, et je lui trouve un intérêt certain,

je n'ai testé que la capture partielle d'un écran
autour de la capture apparaît une série d'icône pour gérer la capture très riche, j'adopte à l'essaie

Merci

Pierre


les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!

Hors ligne

#5 02-12-2019 21:26:46

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 1 204

Re : PrimTux4 pour Raspberry Pi 4ème génération

Philippe Dpt35 a écrit :

Oui, à condition de le faire sur une Raspbian Buster !

Oui, c'était sous-entendu.
Bon, c'est une bonne nouvelle, y'a plus qu'à.

Hors ligne

#6 04-12-2019 10:31:29

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

Est ce que ton image s'installe également sur une raspberry 3b ou 3B+ ?

Hors ligne

#7 04-12-2019 13:07:49

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

oui !

Hors ligne

#8 08-12-2019 19:18:18

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

Bonjour Philippe
peux tu me donner la marque et le modele de carte que tu utilises en 32 go car je n'ai pas pu transférer l'image avec etcher,
ma carte de 32 go n'était pas suffisante.
Merci
Alain

Hors ligne

#9 08-12-2019 19:38:13

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

J'avais pourtant réduit la taille de la partition de 100 Mo pour éviter ce genre de soucis ! C'est ce que je faisais pour les images 16Go de Raspbian stretch et ça marchait bien. Ce n'est peut-être pas suffisant sur les 32Go.

Un autre utilisateur a réussi l'installation, mais après avoir également dû changer de carte (ça semblait plutôt être un problème de carte défectueuse et non de taille disponible).

J'ai travaillé sur une Sandisk ultra 32 Go.

Hors ligne

#10 08-12-2019 20:01:48

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

P.S.: peux-tu m'indiquer la taille marquée disponible pour ta carte SD. ça me servira pour ajuster la taille de mes images à proposer au téléchargement.

Hors ligne

#11 08-12-2019 21:34:49

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

28,64 goctets

Hors ligne

#12 09-12-2019 05:25:40

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

Il y a effectivement un gros écart, la taille de l'image étant de 29,72 Go.
Pour les prochaines constructions, je réduirai d'1,5 Go, en recommandant d'étendre ensuite sa partition avec raspi-config après installation.

Hors ligne

#13 17-12-2019 17:37:04

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

J'ai mis à disposition une image pouvant être utilisée sur une carte 16 GO:
https://sourceforge.net/projects/primtu … z/download
MD5: https://sourceforge.net/projects/primtu … 5/download

Cette image passera donc sans problème sur une carte 32 GO, même à capacité réduite. En revanche il faudra bien penser à étendre la partition avec raspi-config.

Merci de faire vos retours de tests dans ce fil.

Je rappelle que cette image de PrimTux4, destinée aux RPi 4ème génération, est compatible avec les versions antérieures de Raspberry Pi.

Hors ligne

#14 17-12-2019 18:20:58

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

Bonjour Philippe
Merci pour tes efforts
j'ai téléchargé le md5 mais pour l'image pas moyen...
j'ai ce message
The "/Distribution/Archiv..-16Go.img.gz/downloa" file could not be found or is not available.  Please select another file.
même en rajoutant un d à downloa cela ne fonctionne pas...
Es tu sûr du lien donné ?

Alain

Hors ligne

#15 17-12-2019 20:21:36

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

Oui, c'est le lien accessible depuis cette page : https://sourceforge.net/projects/primtu … imTux-RPi/

Le fichier apparaît bien dans le dossier du dépôt avec Filezilla. ça pourrait bien être un bug avec Sourceforge :
https://sourceforge.net/p/forge/site-support/14580/

Peut-être faut-il attendre un peu, compte-tenu de la taille du fichier, que la mise en miroir puisse se faire.

Hors ligne

#16 21-12-2019 18:37:56

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

Bonjour
ça y est j'ai pu  télécharger , installer l'image et redimensionner la partition (je n'ai pas utilisé raspi config mais l'editeur de parttions gparted
Impeccable

Merci Philippe !

Hors ligne

#17 21-12-2019 19:23:31

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

J'ai corrigé le lien vers l'image 16 Go dans le message #13.
Le lien précédent continuait à renvoyer un message d'erreur. Celui donné maintenant est fonctionnel.

Hors ligne

#18 22-12-2019 10:03:32

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

Bonjour Philippe
voici ce que j'ai comme message après installation des logiciels non libres
Les paquets suivants n'ont pas été correctement installés :
appliplanet-primtux
browser-plugin-gnash
geogebra-classic
instrumentpoche-primtux
logiciels-primtux-maxi
logiciels-primtux-mini
logiciels-primtux-super
matou-matheux-primtux
pepit-primtux
primaths-primtux

Pour résoudre le problème, vous pouvez :
   - relancer l'installation complète


Est ce normal  ?
Alain

Hors ligne

#19 22-12-2019 10:36:22

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

Non.
Je n'ai pas testé l'installation des logiciels complémentaires.
Peut-être des problèmes de dépendances non satisfaites avec Buster.
Je vois ça.

Peux-tu déjà tester l'installation un à un des paquets, et me dire ce que le terminal retourne à chaque fois ?

sudo apt-get install appliplanet-primtux

etc.

Hors ligne

#20 22-12-2019 10:42:48

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

administrateur@raspberrypi:~$ sudo apt-get install appliplanet-primtux
[sudo] Mot de passe de administrateur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
appliplanet-primtux : Dépend: browser-plugin-gnash mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install browser-plugin-gnash
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet browser-plugin-gnash n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « browser-plugin-gnash » n'a pas de version susceptible d'être installée
administrateur@raspberrypi:~$ sudo apt-get install geogebra-classic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet geogebra-classic n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « geogebra-classic » n'a pas de version susceptible d'être installée
administrateur@raspberrypi:~$ sudo apt-get install instrumentpoche-primtux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
instrumentpoche-primtux : Dépend: browser-plugin-gnash mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install logiciels-primtux-maxi
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-maxi : Dépend: geogebra-classic mais il n'est pas installable
                          Dépend: primaths-primtux mais ne sera pas installé
                          Dépend: pepit-primtux mais ne sera pas installé
                          Dépend: matou-matheux-primtux mais ne sera pas installé
                          Dépend: instrumentpoche-primtux mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install logiciels-primtux-maxi
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-maxi : Dépend: geogebra-classic mais il n'est pas installable
                          Dépend: primaths-primtux mais ne sera pas installé
                          Dépend: pepit-primtux mais ne sera pas installé
                          Dépend: matou-matheux-primtux mais ne sera pas installé
                          Dépend: instrumentpoche-primtux mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install logiciels-primtux-super
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-super : Dépend: pepit-primtux mais ne sera pas installé
                           Dépend: matou-matheux-primtux mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install logiciels-primtux-mini
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-mini : Dépend: pepit-primtux mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install matou-matheux-primtux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
matou-matheux-primtux : Dépend: browser-plugin-gnash mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install pepit-primtux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
pepit-primtux : Dépend: browser-plugin-gnash mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$ sudo apt-get install primaths-primtux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
primaths-primtux : Dépend: browser-plugin-gnash mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
administrateur@raspberrypi:~$

Dernière modification par Alain (22-12-2019 11:01:02)

Hors ligne

#21 22-12-2019 10:57:21

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

C'est bien ce qu'il me semblait, des problèmes de paquets et de dépendances plus disponibles dans Buster.
Je vais voir au cas par cas ce qu'il est possible de faire, mais ça demandera un peu de temps.

Hors ligne

#22 22-12-2019 11:30:50

Alain
Membre
Inscription : 20-07-2017
Messages : 243

Re : PrimTux4 pour Raspberry Pi 4ème génération

rien ne presse ...
Plus embêtant pour moi  c'est l'impossibilité d'installer le serveur lampp
j'ai ces messages
lampp-primtux-rpi:
Dépend: php7.0  but it is not installable
Dépend: php7.0-mysql  but it is not installable
Dépend: mysql-server  but it is not installable

sur la version précédente  primtux3 avec stretch j'avais pu l'installer mais pas configurer le hotspot

Ici c''est dommage car j'avais réussi à mettre le hotspot  mais manque de pot lampp ne veut pas s'installer...

Hors ligne

#23 22-12-2019 11:53:14

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 942

Re : PrimTux4 pour Raspberry Pi 4ème génération

et nginx?

Hors ligne

#24 22-12-2019 12:08:25

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 227
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

Pour lampp, c'est normal, car pour php on doit être à la version7.3 (de mémoire).
Pour mysql-server, il faut voir.

Nginx doit être installé avec CTparental. Tu dois donc déjà avoir un serveur Web.

Hors ligne

#25 22-12-2019 12:11:45

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 942

Re : PrimTux4 pour Raspberry Pi 4ème génération

Ah ok, je pensais qu'il avait son propre lamp comme xampp.

Hors ligne

Pied de page des forums