PrimTux

La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

CARTE DES MEMBRES POUVANT AIDER ET DES ÉCOLES SOUS PRIMTUX
Merci de vous y inscrire en nous envoyant un email si vous souhaitez y apparaître.

Les différentes isos de PrimTux4 sont disponibles, cliquez ici pour choisir votre version.
  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 26-11-2018 14:48:22

Stef09
Membre
Lieu : Ariège
Inscription : 12-12-2017
Messages : 5

Exécuter un script à l'ouverture de session ?

Bonjour,

j’éprouve des difficultés à fixer mon partage réseau. Celui-ci s'effectue sur un NAS Synology.
une commande sudo mount fait bien monter le partage. Je l'ai fixé dans le fichier 'fstab', mais au redémarrage celui-ci n'est plus opérationnel. Si on clique l'icône du partage dans l'explorateur de fichier(pcmanfm), on obtient un message "seuls les administrateurs ont le droit de faire cela." Une commande sudo mount (mount -a //192.168.x.x/repertoire_partage /media/administrateur/repertoire_monte) suffit à rétablir le partage, d'où mon idée de lancer une commande mount par l'intermédiaire d'un script à l'ouverture de la session.
Pour l'instant je fais des tests au niveau de l'administrateur, mais l'idée ce serait de mettre le point de montage dans le répertoire Documents des sessions 'élève'

ma ligne dans le fstab:
//192.168.x.x/repertoire_partage /media/administrateur/repertoire_monte cifs credentials=/home/administrateur/.credentials,auto,rw 0 0

mon script mount.sh
mount -a //192.168.x.x/repertoire_partage /media/administrateur/repertoire_monte
(si je fais sudo bash mount.sh, le script fonctionne, mon partage réseau se rétablit instantanément)

mon fichier .credentials
username=xxxxx
password=xxxxx

comme vu sur un forum Debian,
j'ai essayé de mettre mon script dans /etc/init.d
j'ai fait un chmod dessus et un     
update-rc.d mon_script.sh defaults
mais je ne sais pas si c'est vraiment bon... en tout cas cela reste sans résultat (toujours le même message d'erreur)

une idée pour exécuter ce script à l'ouverture de session ?

merci à tous

Hors ligne

#2 26-11-2018 17:09:59

Alain
Membre
Inscription : 20-07-2017
Messages : 189

Re : Exécuter un script à l'ouverture de session ?

Bonjour
as tu essayé cette ligne dans fstab  avant de faire sudo mount -a ?

//192.168.x.x/repertoire_partage  /media/repertoire_monte  cifs soft,file_mode=0666,dir_mode=0777,user,username=xxxx,password=xxxx,iocharset=utf8  0 0

Hors ligne

#3 26-11-2018 20:08:12

Stef09
Membre
Lieu : Ariège
Inscription : 12-12-2017
Messages : 5

Re : Exécuter un script à l'ouverture de session ?

Merci Alain,
ça marche. smile
du coup, comment sécuriser un peu ce fichier fstab qui contient le mot de passe ?

encore merci

Hors ligne

Pied de page des forums