NOUVELLE ADRESSE PERMANENTE DU DÉPÔT: https://mirrors.o2switch.fr/primtux/repo/debs
ATTENTION, MERCI DE NE PAS METTRE À JOUR PRIMTUX7 UBUNTU 20.04 VERS LA 22.04, LES HANDYMENUS NE SONT PAS ENCORE COMPATIBLES!
Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Dépendances non satisfaites
#1
Tout dabord je suis sous un ordinateur portable avec PrimTux5-Debian9-i386.hybrid,

mon soucis c'est que lorsque je souhaite installer des logiciels supplémentaires j'ai en grande majorité un message de dépendances non satisfaites et de logiciels non installables.

Est-ce normal vu que ce n'est pas la dernière version de Primtux ou il y a t'il quelque chose à faire de particulier pour résoudre ce problème ?

Merci d'avance !
Répondre
#2
Peux-tu nous faire un copié-collé de ce que renvoie la console ?
Répondre
#3
Atteint:1 http://depot.primtux.fr/repo/debs PrimTux2-Stretch InRelease
Atteint:3 http://www.geogebra.net/linux stable InRelease
Atteint:4 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu xenial InRelease
Atteint:5 http://depot.primtux.fr/repo/debs PrimTux5-i386 InRelease
Atteint:6 http://depot.primtux.fr/repo/debs PrimTux4 InRelease
Atteint:2 http://depot.primtux.fr/repo/debs PrimTux2 InRelease
Atteint:7 http://ppa.launchpad.net/exelearning/exelearning/ubuntu bionic InRelease
Ign:2 http://depot.primtux.fr/repo/debs PrimTux2 InRelease
Atteint:9 http://ppa.launchpad.net/jclic/master/ubuntu trusty InRelease
Atteint:8 http://depot.primtux.fr/repo/debs PrimTux2 Release
Ign:10 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Atteint:12 http://cdn-fastly.deb.debian.org/debian stretch Release
Lecture des listes de paquets... Fait
W: Distribution en conflit : http://depot.primtux.fr/repo/debs PrimTux2 Release (PrimTux2 attendu, mais PrimTux4 obtenu)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet tuxbot-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « tuxbot-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
scratch2-primtux is already the newest version (454-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet iqpuzzle n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « iqpuzzle » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
gcompris-qt-primtux is already the newest version (0.97).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
jclicpuzzle-primtux is already the newest version (1.0.0).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet pepit-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « pepit-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
matou-matheux-primtux : Dépend: flash-primtux mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
kiwix-vikidia-primtux is already the newest version (1.3.6).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
activites-jclic-primtux is already the newest version (2.1.2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet jelisavecbiba-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « jelisavecbiba-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet exooos-aleccor-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « exooos-aleccor-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet exercices-free-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « exercices-free-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
exercices-beaunis-primtux is already the newest version (1.1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
clicmenu-super-primtux is already the newest version (1.3.10).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 153 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet raconte-moi-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « raconte-moi-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-super : Dépend: tuxbot-primtux:i386 mais il n'est pas installable
Dépend: iqpuzzle:i386 mais il n'est pas installable
Dépend: pepit-primtux mais il n'est pas installable
Dépend: matou-matheux-primtux mais ne sera pas installé
Dépend: jelisavecbiba-primtux mais il n'est pas installable
Dépend: exooos-aleccor-primtux mais il n'est pas installable
Dépend: exercices-free-primtux mais il n'est pas installable
Dépend: raconte-moi-primtux mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Les paquets suivants n'ont pas été correctement installés :
tuxbot-primtux
iqpuzzle
pepit-primtux
matou-matheux-primtux
jelisavecbiba-primtux
exooos-aleccor-primtux
exercices-free-primtux
raconte-moi-primtux
logiciels-primtux-super

Pour résoudre le problème, vous pouvez :
- relancer l'installation complète
ou
e - installer individuellement les paquets manquants.
Répondre
#4
Je vois qu'il y a 153 paquets non mis à jour.
Peux-tu commencer par faire un
Code :
sudo apt-get update & sudo apt-get dist-upgrade

puis relance l'installation des logiciels complémentaires.
Répondre
#5
Les mises à jour se sont bien passées, j'ai rebooté puis tenté à nouveau l'installation de logiciels supplémentaires mais j'obtient ceci :

[sudo] Mot de passe de administrateur : 
Atteint:2 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu xenial InRelease
Atteint:3 http://ppa.launchpad.net/exelearning/exelearning/ubuntu bionic InRelease
Atteint:4 http://www.geogebra.net/linux stable InRelease
Atteint:5 http://ppa.launchpad.net/jclic/master/ubuntu trusty InRelease
Atteint:6 http://depot.primtux.fr/repo/debs PrimTux2-Stretch InRelease
Atteint:8 http://depot.primtux.fr/repo/debs PrimTux5-i386 InRelease
Atteint:9 http://depot.primtux.fr/repo/debs PrimTux4 InRelease
Atteint:7 http://depot.primtux.fr/repo/debs PrimTux2 InRelease
Ign:7 http://depot.primtux.fr/repo/debs PrimTux2 InRelease
Atteint:10 http://depot.primtux.fr/repo/debs PrimTux2 Release
Ign:1 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Atteint:12 http://cdn-fastly.deb.debian.org/debian stretch Release
Lecture des listes de paquets... Fait
W: Distribution en conflit : http://depot.primtux.fr/repo/debs PrimTux2 Release (PrimTux2 attendu, mais PrimTux4 obtenu)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet tuxbot-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « tuxbot-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
scratch2-primtux is already the newest version (454-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet iqpuzzle n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « iqpuzzle » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
gcompris-qt-primtux is already the newest version (0.97).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
jclicpuzzle-primtux is already the newest version (1.0.0).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet pepit-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « pepit-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
matou-matheux-primtux : Dépend: flash-primtux mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
kiwix-vikidia-primtux is already the newest version (1.3.6).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
activites-jclic-primtux is already the newest version (2.1.2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet jelisavecbiba-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « jelisavecbiba-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet exooos-aleccor-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « exooos-aleccor-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet exercices-free-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « exercices-free-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
exercices-beaunis-primtux is already the newest version (1.1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
clicmenu-super-primtux is already the newest version (1.3.10).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet raconte-moi-primtux n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « raconte-moi-primtux » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
logiciels-primtux-super : Dépend: tuxbot-primtux:i386 mais il n'est pas installable
Dépend: iqpuzzle:i386 mais il n'est pas installable
Dépend: pepit-primtux mais il n'est pas installable
Dépend: matou-matheux-primtux mais ne sera pas installé
Dépend: jelisavecbiba-primtux mais il n'est pas installable
Dépend: exooos-aleccor-primtux mais il n'est pas installable
Dépend: exercices-free-primtux mais il n'est pas installable
Dépend: raconte-moi-primtux mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Les paquets suivants n'ont pas été correctement installés :
tuxbot-primtux
iqpuzzle
pepit-primtux
matou-matheux-primtux
jelisavecbiba-primtux
exooos-aleccor-primtux
exercices-free-primtux
raconte-moi-primtux
logiciels-primtux-super

Pour résoudre le problème, vous pouvez :
- relancer l'installation complète
ou
e - installer individuellement les paquets manquants.
Répondre
#6
ça n'a pas changé énormément de choses. En revanhce, je vois des choses surprenantes au niveau des dépôts. Notamment des dépôts ubuntu alors que tu es sur une Debian.
As-tu ajouté manuellement des dépôts ?
Répondre
#7
Non pas d'ajout de dépôts, je me suis dis effectivement qu'il n'allait pas chercher les bons paquets ou bien que c'est une version trop ancienne pour certains logiciels mais j'ai déjà eu ce problème sur d'autres version de Primtux, peut-être les serveurs de dépôts ne sont pas toujours disponibles ?
Répondre
#8
Tout ça est normal et anormal à la fois, anormal parce que je n'ai pas mis à jour les logiciels supplémentaires de la 5 (oubli), normal en somme qu'il ne trouve pas certains logiciels vu qu'ils n'y sont plus!
Répondre
#9
Normalement c'est corrigé, il faut mettre à jour via synaptic puis redémarrer l'accueil.
Répondre
#10
Merci cela fonctionne. Wink
Seul petit problème c'est que le profil firefox n'est plus le même, j'ai du forcé la sécurité pour atteindre le panneau du contrôle parental puis mettre en manuel les plugins qwant junior et ublock origin.
Répondre
#11
C'est la mise à jour qui fait ça. Entre la 5 et la 6 la gestion des profils a changé sous firefox, ceux d'origine ne sont donc plus compatibles et dans ce cas firefox en recrée un.
Répondre
#12
Est-ce que la solution la plus saine ne serait pas d'avoir un dépôt spécifique PTX6 qui viendrait écraser la config firefox ?
Répondre
#13
Le fichiers de configuration sont das les home, impossible avec un deb.
Répondre
#14
Ah oui, c'est plutôt lié à la monté de version de Firefox si je comprend bien.
Répondre
#15
oui, les répertoires ne sont plus nommés de la même façon.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)