Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Tests PrimTux6 RPi
Merci Philippe,
En fait en passant par le menu "Préférences Élèves", comme on peut configurer le CT, on peut aussi le mettre en raccourci dans la barre personnelle.

Je suis donc en train de tester la dernière version :
- Openboard : ça fonctionne sauf l'annotation d'écran où tout devient noir quand on veut annoter (mais pour moi l'essentiel fonctionne).
- Xournal++ : toujours le problème de zoom. Je vais regarder s'il y a eu une évolution officielle de ce côté-là (la dernière fois que je m'y étais penché, c'était en cours de résolution mais faut que je m'y replonge).
- Concernant les problèmes de son (indépendant de Primtux, c'est inhérent au Raspi), le mieux c'est d'utiliser des haut-parleurs (mais avec un bruit de fond lié à l'alimentation) ou casques avec prise USB plutôt que jack. Avec ce matériel pas besoin de mettre les mains dans le cambouis.
- Scratch 3 : pas de souci
- LibreOffice des Écoles (writer) : tout fonctionne y compris la synthèse vocale (qui pour moi est un atout majeur).
- Audacity : fonctionne avec un message d'erreur au premier lancement mais qu'on peut choisir d'ignorer pour les prochaines fois.
- Je n'ai pas testé les "exerciseurs" mais Calcul@tice n'est plus présent (j'ai dû louper une info Wink ).

Suggestions :
- on pourrait rajouter l'application "xfce4-clipman" comme gestionnaire de presse-papier avec lancement automatique via FluxboxLauncher (au moins pour l'administrateur).
- Est-il possible d'utiliser Veyon (sucesseur d'iTALC) https://docs.veyon.io/fr/latest/admin/introduction.html pour superviser des ordi sous Primtux, est-ce que quelqu'un a testé ?

Cordialement,

Thierry
Répondre
Re-Adieu a totes,

Je viens de compiler Xournal++ (le bug du zoom a disparu) et de l'empaqueter. Il est téléchargeable ici : https://nuage-montpellier.beta.education...J45cymBAFm
Pourriez-vous le tester pour voir s'il peut être intégré dans Primtux6 ?
Cordialement,

Thierry
Répondre
En fait perso je préfère le xournal, j'ai même envie de faire un retour arrière...
Répondre
Adieu,
Pourquoi dans ce cas, si c'est possible, ne pas proposer les 2 (Xournal et Xournal++) comme pour les différentes versions de Scratch ?
Cordialement,

Thierry
Répondre
Adieu a totes,

Je ne vais pas tarder à déployer 20 Raspberry Pi 4 4 Go sous Primtux pour une école n'ayant que des cycles 3. Comme cette école possède une imprimante 3D, j'ai installé des applications spécifiques pour ce pilotage (Arduino IDE, CURA et BlockSCAD). Comme c'est plutôt une utilisation marginale, je ne vois pas trop l'intérêt de proposer ces logiciels spécifiques par défaut dans Primtux d'autant que certains dépendent du matériel et de ses pilotes.
Par contre, je pense que ça pourrait être intéressant pour le cycle 3 de proposer en version hors-ligne BlockSCAD, ce qui peut être fait en lançant le fichier "index.html" de l'archive téléchargée : https://github.com/EinsteinsWorkshop/BlocksCAD
Création d'un lanceur avec cette ligne de commande :
Code :
firefox %u "file:///home/administrateur/Téléchargements/BlocksCAD/index.html?lang=fr#"

Si vous voulez avoir plus d'information sur l'utilisation de Primtux pour piloter une imprimante 3D, vous pouvez voir cette page : https://lofurol.fr/joomla/impression-3d/...s-primtux6
Cordialement,

Thierry
Répondre
Adieu a totes,

J'ai continué mes recherches concernant la préparation d'un Raspberry Pi 4 Primtux "technologique" pour permettre de programmer un robot Edison. Pour ne pas surcharger ici, j'ai mis des infos sur cette page : https://lofurol.fr/joomla/electronique/2...tedison-v2
J'ai été bien content que la version de Firefox pour Primtux soit une ESR car ça m'a permis de rajouter une extension non signée traduisant l'interface de programmation EdScratch en français (chose impossible sur une version classique de Firefox). Un autre contournement aurait été de passer par Chromium qui lui possède une extension "officielle" de traduction.
Cordialement,

Thierry
Répondre
J'ai installé une img il y a quelques mois.

En me remettant dessus, je me rend compte que un "apt-get update" ne marche plus.
A priori, l'url du dépôt a changé. Il faut éditer son source.list :

Code :
deb https://archive.raspbian.org/raspbian buster main contrib non-free

avant c'était :

Code :
deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
Répondre
Je viens de vérifier chez moi avec apt, mais il n'y a pas de raison que cela soit autrement avec apt-get. J'ai toujours l'adresse http://raspbian.raspberrypi.org/ dans mon source.list, et update a fonctionné. Mais il m'a fallu le relancer 2 ou fois avant qu'il ne me donne la liste des paquets pouvant être mis à jour. Et j'ai pu faire la mise à jour.
Répondre
Adieu,
Je n'ai pas constaté ce problème de mise à jour mais c'est vrai que je les fais assez régulièrement (pas de trop longues périodes sans mise à jour).
Cordialement,

Thierry
Répondre
Adieu a totes,

En refaisant une installation de zéro (impossible de cloner la carte microSD initiale pourtant fonctionnelle sans plantage au démarrage...), je me suis rendu compte que Géogébra n'était pas installé via les paquets supplémentaires. J'ai dû passer par un "sudo apt install geogebra".
Serait-il possible de l'ajouter dans la liste des paquets supplémentaires pour le cycle 3 ?
Merci. Cordialement,

Thierry
Répondre
Vu qu'il va me falloir plonger bientôt dans la construction de la PrimTux7 RPi, je ne suis pas motivé pour revoir les paquets de la PTx6 compte-tenu des nombreuses contraintes que j'ai par ailleurs !
ça attendra bien la PTx7, d'autant plus qu'un
sudo ap install geogebra
est loin d'être insurmontable ! Wink
Répondre
Pas de problème pour moi Philippe. Wink
As-tu une idée du nombre d'utilisateur⋅rice⋅s de ces versions pour Raspberry Pi ? Quelles améliorations justifient la montée de version alors que personnellement, la Primtux6 RPi me semble parfaitement convenir ?
Tu pourras compter sur mes modestes retours (même si je ne prévois pas d'autres installations de Primtux sur des Raspi 4 dans les prochains mois).
Cordialement,

Thierry
Répondre
ThierryM a écrit :As-tu une idée du nombre d'utilisateur⋅rice⋅s de ces versions pour Raspberry Pi ?
Aucune, mais je pense qu'ils ne sont pas négligeables, au détour d'articles que l'on peut trouver sur elle sur le Net.
Citation :Quelles améliorations justifient la montée de version alors que personnellement, la Primtux6 RPi me semble parfaitement convenir ?
Elle sera encore plus mieux ! :lol:
Citation :Plus sérieusement : harmonisation avec la version desktop, passage à Debian 11.
Répondre
Merci pour toutes ces précisions.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)