NOUVELLE ADRESSE PERMANENTE DU DÉPÔT: https://mirrors.o2switch.fr/primtux/repo/debs
ATTENTION, MERCI DE NE PAS METTRE À JOUR PRIMTUX7 UBUNTU 20.04 VERS LA 22.04, LES HANDYMENUS NE SONT PAS ENCORE COMPATIBLES!
Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
installation Thorium Reader sur Primtux 4
#1
Bonjour, je tente d'installer ce lecteur d'epub, mais il ne se lance pas. Lors de la première installation, il n'y avait pas d'icône associée dans le menu. J'ai donc rajouté une icône, mais rien ne se passe...
Une seule version pour Linux est disponible : https://www.actualitte.com/article/lectu...inux/98877

Je suis sur une version de Primtux 4 , Lubuntu, sur un Chromebook.
Répondre
#2
Alors c'est une application portée depuis android, on a une utilisation processeur à 100%. Pour le bien il faudrait la recompiler avec un node.js d'une autre version... Pas gagné.
Répondre
#3
Quand j'essaye de le lancer via le terminal, j'ai ce message d'erreur : [Image: 7617c7d7ace7ff377de6c3f08ef866ec.png]
Répondre
#4
Oui, c'est une application android popréte sur linux, parfois ça passe, d'autres fois non...
Répondre
#5
Tu peux donner le résultat de :

Code :
apt-cache policy libc6

Sinon, si tu veux lire de l'epub, y'a ce qu'il faut : https://doc.ubuntu-fr.org/epub
Répondre
#6
Tu as d'autres options :
- lancer la version windows via wine
- compiler à partir des sources : https://github.com/readium/readium-desktop

rappel moi, @Steph, la Primtux 4 c'est quel version d'Ubuntu ? (je veux essayé de triché pour effectuer la compil sur github)
Répondre
#7
18.04. Des electron via wine oublie, par contre avec d'autres versions de node.js, voire même du 32 bits ça peut passer, j'ai testé avec scratch3 et scratchJr et je suis arrivé à un résultat: la scratch3 64 bits agit comme le thorium 64bits (100%CPU et ne démarre pas ou avec difficulté). Compilé en 32 bit avec le dernier electron compatible 32 bits (3.1.13) et node.js qui va avec, ça passe: https://github.com/electron/electron/rel...ag/v3.1.13
Répondre
#8
Un peu tard...


Code :
Installé : 2.27-3ubuntu1
  Candidat : 2.27-3ubuntu1
Table de version :
*** 2.27-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status


J'étais intéressée par cette application, car elle permet de lire de l'epub 3.
Répondre
#9
Bon, alors : pas de bol, tu es sur une glibc 2.27 au lieu de 2.28 et le soft a été compilé avec la 2.28 ce qui sous-entend que ce n'est pas ABI compatible.
Je ne comprend pas pourquoi ils fournissent un .deb qui s'appuie sur une libc aussi récente. (sans doute une limitation technique lié à chromium)

Vu que la Primtux 5 s'appui également sur la Lubuntu 18.4, tu auras le même soucis si tu montes de version.
A part la compilation à partir des sources, j'ai malheureusement pas de solution miracle.

En revanche, pour lire de l'epub3, je pense qu'il existe quand même des softs qui devrait correspondre.
Tu as un fichier en particulier à nous proposer ?

Dans la liste https://fr.wikipedia.org/wiki/EPUB_(format), j'ai "Calibre" qui supporte le format.
Répondre
#10
Je confirme avoir installé calibre sur un primtux5 64 bits (lubuntu 18.04).
J'ai réussi à lire un epub3 fabriqué avec bookcreator. La vidéo fonctionne bien que saccadée. On entend le son de la vidéo très fort. On doit pouvoir le régler quelque part.
Par contre, aucun des deux fichiers sons présents dans le bouquin ne sont audibles.

Par ailleurs, je viens d'installer thorium sur le même poste (EDRLab.ThoriumReader_1.1.0_amd64.deb) et il ne fonctionne pas. Sur un autre ordi avec ubuntu 18.04, il fonctionne très bien...
Répondre
#11
jdye a écrit :et il ne fonctionne pas.

Su tu le lances à partir d'un terminal, ça dit quoi ?
Répondre
#12
Merci pour vos réponses er recherches. Voici un lien pour télécharger un exemple d'epub3 contenant son, image et vidéo : https://send.firefox.com/download/b3a65a...Y24znLYImQ
Répondre
#13
J'ai testé une appimage avec compilation de glibc2.28 sous ubuntu 18.04 inclus, et j'ai ce message, sans démarrage:

Code :
'g_io_module_load': /usr/lib/x86_64-linux-gnu/gio/modules/libgvfsdbus.so: undefined symbol: g_io_module_load
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgvfsdbus.so
Gtk-Message: 18:59:11.639: Failed to load module "canberra-gtk-module"
Gtk-Message: 18:59:11.642: Failed to load module "canberra-gtk-module"
Erreur de segmentation
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)