PrimTux, la distribution éducative
[Résolu] Problème résolution écran qui bloque Dell Optiflex 745 - Version imprimable

+- PrimTux, la distribution éducative (https://forum.primtux.fr)
+-- Forum : Discussions générales (https://forum.primtux.fr/forumdisplay.php?fid=7)
+--- Forum : Discussions générales (https://forum.primtux.fr/forumdisplay.php?fid=27)
+--- Sujet : [Résolu] Problème résolution écran qui bloque Dell Optiflex 745 (/showthread.php?tid=1647)



[Résolu] Problème résolution écran qui bloque Dell Optiflex 745 - ThierryM - 07-12-2021

Adieu a totes,

Je poste ici car j'ai un problème avec des Dell Optiflex 745 (Intel Celeron 420 @1.6 Ghz, 1 Go de Ram) qui se bloquent une fois le démarrage effectué. Apparemment c'est la carte graphique intégrée (Intel 82Q963/Q965) qui ne suivrait pas.
Ce n'est pas un problème spécifique à Primtux, car j'ai le même effet avec d'autres distributions (en i686 ou AMD64).
J'ai écumé le Web mais sans résultats concluant (voir ici par exemple : https://ubuntuforums.org/showthread.php?t=2339568&s=0cb5a59acdd96b041de2189faf292533&p=13556613#post13556613).
Vu que ça bloque (impossible de passer en mode console : d'ailleurs ça serait intéressant de proposer ce type de démarrage via Grub), je passe par un live CD System Rescue en mode texte (car la session graphique plante elle-aussi) pour agir sur la configuration de Primtux.

Par contre, comment faire pour modifier la résolution de Lightdm au départ ?

Merci pour vos éclairages, cordialement,

Thierry


RE: Problème résolution écran qui bloque Dell Optiflex 745 - Steph - 09-12-2021

Ouh là ça je ne sais pas, peut être mettre un fond qui correspond à la résolution voulue...


RE: Problème résolution écran qui bloque Dell Optiflex 745 - ThierryM - 09-12-2021

Adieu Stéph,

Après avoir pas mal cherché et être parti dans tous les sens (j'ai même réussi à mettre à jour le BIOS en bootant avec FreeDOS : https://www.dell.com/support/kbdoc/fr-fr/000131486/update-the-dell-bios-in-a-linux-or-ubuntu-environment), je me suis rappelé d'un problème similaire il y a quelques années à propos d'une option à rajouter dans Grub.
Du coup, j'ai retrouvé cette option qui a "corrigé" le problème (j'allais baisser les bras...) :

Code :
acpi=off

Du coup, j'en ai profité aussi pour rajouter aussi les options "acpi=off noapic nolapic pnpbios=off" dans le grub.

Pour que les modifications soient pérennes au démarrage, il faut modifier le fichier "/etc/default/grub" et compléter la ligne :
Code :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off noapic nolapic pnpbios=off"

Ensuite on n'oublie pas de reconstruire le grub avec la commande :
Code :
sudo update-grub

Plus de problème de mise en veille forcée de l'écran au démarrage.
Pour info, avec cette manip, les résolutions d'écran disponibles se limitent à 5 ou 6 et à du 1600x1200 maxi (alors qu'avant j'avais du 1920x1080 d'office...).
Dernière précision, sur ces modèles de Dell (Intel celeron 420 @1.6 Ghz, HD de 80 Go, 1 Go de ram), j'ai installé Primtux 7 Debian 9 i386.
En espérant que ça puisse servir à d'autres.
Cordialement