La nouvelle distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

PRIMTUX2 EST DISPONIBLE SUR SOURCEFORGE.
Somme MD5: f4a4f6523990258fd9653ff78f2fb3d4

#1 07-03-2017 21:00:10

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 1 768

changement de noyau pour carte graphique intégrée NVIDIA

Bonjour,

sur un PC portable ACER Aspire 5612 WLMi de janvier 2006, avec une carte graphique NVIDIA, lorsque je lançais Ri-Li, cela plantait l'affichage.

La solution qui marche pour obtenir un affichage de bien meilleure qualité est le changement de noyau.

Steph a écrit :

Comme c'est un pb de driver, essaie de changer de noyau:

Paramètres => gestionnaire de paquets =>synaptic => configuration => dépôts => onglet autres logiciels => ajouter => copie-colle cette ligne:

=> ajoute

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

=> recharge et recherche linux-image => choisis la 4.9.0-0.bpo.1-686-pae (la première fois il m'a dit qu'il fallait un linux-base plus récent, j'ai désélectionné le noyau, puis je l'ai resélectionné et il m'a inclus la mise à jour de linux-base).

Au reboot, choisir les options avancées et démarrer avec le noyau 4.9

Steph a écrit :

Sélection_082.png

Tu cherches linux-image et tu installes celui-là: linux-image-4.9.0-0.bpo.1-686-pae

Au reboot, le PC démarre sur ce nouveau noyau. smile

Hors ligne

#2 10-03-2017 10:53:54

4kristof6
Membre
Inscription : 18-09-2015
Messages : 28

Re : changement de noyau pour carte graphique intégrée NVIDIA

Bonjour,

Même souci ici sauf que mon seul accès est en ssh, l'interface graphique ne fonctionne pas avec "nouveau" (kernel panic), "nvidia 304.xxx" installé mais rien sad

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6100 nForce 405] (rev a2)
Kernel driver in use: nvidia

Bref, j'ai ajouté les backports au source.liste et voici la réponse (mais moi je ne peux pas décocher/cocher la case lol )

root@primtux:/home/administrateur# apt install linux-image-4.9.0-0.bpo.1-686-pae
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-4.9.0-0.bpo.1-686-pae : Dépend: linux-base (>= 4.3~) mais 3.5 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Si vous aviez une suggestion ?

Sincèrement,

Christophe

Hors ligne

#3 10-03-2017 12:20:17

Steph
Administrateur
Inscription : 03-06-2015
Messages : 3 049

Re : changement de noyau pour carte graphique intégrée NVIDIA

As-tu rechargé avant? J'avais eu ce tour et un apt-get update l'avait résolu.

Hors ligne

#4 13-03-2017 14:33:36

4kristof6
Membre
Inscription : 18-09-2015
Messages : 28

Re : changement de noyau pour carte graphique intégrée NVIDIA

Bonjour,

Il manquait l'option "jessie-backports"

root@primtux:~# apt -t jessie-backports install linux-image-4.9.0-0.bpo.2-686-pae

Hors ligne

Pied de page des forums