La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

PrimTux3-Raspberry Pi est disponible pour tests ici

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Carte des membres pouvant aider et des écoles sous PrimTux, merci de nous envoyer un email si vous souhaitez y apparaître.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 07-02-2016 19:44:19

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

[RESOLU] impossible d'installer webstrict

hello

j'suis tout nouveau. j'installe Primtux pour la p'tite qui a 7 ans.
Impossible d'installer webstrict : synaptic m'indique immédiatement qu'il y a 1 paquet cassé

j'ai bien ajouté la clé gpg pour le depot Primtux
j'ai installé java9

j'ai rechargé synaptic
en root, j'ai fait un apt-get install -f, nada


synaptic continue de hurler que "Impossible d'appliquer les changements, réparez d'abord les paquets cassés"
j'ai essayé le lien Réparer les paquets cassés dans le menu édition, là ca hurle "Impossible de corriger les problèmes des paquets defectueux sont en mode 'garder en l'état'"

help

Dernière modification par kallagan (08-02-2016 08:04:11)

Hors ligne

#2 07-02-2016 19:46:49

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 429

Re : [RESOLU] impossible d'installer webstrict

Salut kallagan,

En théorie un sudo apt-get install -f te répare ça, c'est bizarre.

Essaie sudo dpkg --configure -a

Hors ligne

#3 07-02-2016 19:57:51

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

Re : [RESOLU] impossible d'installer webstrict

ouah quelle rapidité de réponse wink

c'est ce que je me suis dit aussi pour l'install -f
d'autant que l'install est vraiment fraiche. j'ai juste configuré le wifi, supprimé un utilisateur (la petite tranche d'âge) et changé le .face d'un autre.

Dernière modification par kallagan (07-02-2016 19:58:56)

Hors ligne

#4 07-02-2016 20:00:58

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

Re : [RESOLU] impossible d'installer webstrict

le dpkg aide pô non plus sad

voilà ce que j'ai en ligne de commande :

# apt-get install webstrict-primtux
Lecture des listes de paquets... Fait
Construction de l'arbre des dpendances       
Lecture des informations d'tat... Fait
Certains paquets ne peuvent tre installs. Ceci peut signifier
que vous avez demand l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
t crs ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider  rsoudre la situation:

Les paquets suivants contiennent des dpendances non satisfaites:
webstrict-primtux : Dpend: dansguardian-primtux (>= 1.1) mais 1.0 devra tre install
E: Impossible de corriger les problmes, des paquets dfectueux sont en mode garder en l'tat.

Hors ligne

#5 07-02-2016 20:02:32

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

Re : [RESOLU] impossible d'installer webstrict

et :

# dpkg -l | grep dansguardian
ii  dansguardian-primtux                  1.0                                  i386         Filtrage web pour PrimTux. N'oubliez pas de configurer le navigateur web.

on dirait que le paquet webstrict-primtux attend dansguardian1.0 alors que c'est dansguardian-primtux qui est déjà installé

Hors ligne

#6 07-02-2016 22:02:22

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 429

Re : [RESOLU] impossible d'installer webstrict

Tu as mis à jour dansguardian après avoir rechargé les paquets? Parce que dans le dépôt dansguardian-primtux en est à la 1.2.

Hors ligne

#7 08-02-2016 07:24:25

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 429

Re : [RESOLU] impossible d'installer webstrict

Voilà c'est de ma faute, j'ai forké tinyproxy et je n'ai pas changé les dépendances de webstrict. Donc tu recharges par synaptic et tu installes webstrict, tu édites le raccourcis si besoin (rappel: http://wiki.primtux.fr/doku.php/premier … accourcis), webstrict est dans la catégorie "Configuration des compilations".

Hors ligne

#8 08-02-2016 08:03:58

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

Re : [RESOLU] impossible d'installer webstrict

j'viens d'installer webstrict-primtux à distance via ssh. Je testerai ce soir à l'usage mais déjà l'install fonctionne wink

merci pour ta réactivité

Hors ligne

#9 08-02-2016 08:19:36

kallagan
Membre
Inscription : 07-02-2016
Messages : 6

Re : [RESOLU] impossible d'installer webstrict

de loin, ça sent plutôt bon :

dansguardian

Hors ligne

Pied de page des forums