PrimTux

La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

CARTE DES MEMBRES POUVANT AIDER ET DES ÉCOLES SOUS PRIMTUX
Merci de vous y inscrire en nous envoyant un email si vous souhaitez y apparaître.

Les différentes isos de PrimTux4 sont disponibles, cliquez ici pour choisir votre version.
  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 30-11-2019 22:04:58

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

PrimTux4 pour Raspberry Pi 4ème génération

L'image de PrimTux4 RPi proposée en téléchargement, bâtie sur Raspbian Stretch, n'est pas compatible avec le nouveau Raspberry Pi, version 4. Il faut pour cela utiliser Raspbian Buster (Debian 10).

J'ai construit une PrimTux4 sur Raspbian Buster afin de la rendre compatible avec le RPi4. Cette image a besoin d'être testée avant d'en faire une diffusion publique.

Merci donc à ceux qui voudront bien la tester.

Pour ceux qui le souhaitent, il est également possible de la construire soi-même grâce à un script de construction. Voir ici : https://framagit.org/philippe-dpt35/primtux4-rpi4

L'image prête à l'emploi est téléchargeable ici : https://sourceforge.net/projects/primtu … z/download

Somme md5: https://sourceforge.net/projects/primtu … 5/download

Cette image nécessite l'utilisation d'une carte SD de 32 Go minimum.

Limitations de cette version :

Certains paquets ne s'installent pas, soit  parce qu'ils sont obsolètes, soit parce qu'ils ont des dépendances non satisfaites parce qu'elles sont manquantes. C'est le cas de leterrier-aller, openboard et solydxk-softwaremanager (gestionnaire de logiciels)

lsb-compat, qui permet l'installation de certains pilotes de scanners, n'est plus disponible.

Shutter n'est pas installable en raison d'une dépendance abandonnée dans Buster. Je l'ai remplacé par Flameshot.

Merci de faire vos retours dans ce fil de discussion, aussi bien sur le script que sur l'image prête à graver.

Cette version est utilisable sur les générations précédentes de Raspberry Pi.

Hors ligne

#2 30-11-2019 23:17:35

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 982

Re : PrimTux4 pour Raspberry Pi 4ème génération

Si je comprend bien, c'est la raspbian Stretch qui n'est pas compatible rpi4 ?
Si c'est bien ça, ça veux dire que je peux compiler sur une rpi3.

Je vais participer à l'effort de guerre en me concentrant sur openboard puis letterier-aller.

C'est dommage pour Shutter. Je ne sais pas ce que vaut Flameshot mais si je galère pas trop sur les 2 premiers, je regarderais également.

Hors ligne

#3 01-12-2019 00:06:44

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

mothsart a écrit :

Si je comprend bien, c'est la raspbian Stretch qui n'est pas compatible rpi4 ?
Si c'est bien ça, ça veux dire que je peux compiler sur une rpi3.

Oui, à condition de le faire sur une Raspbian Buster !

Hors ligne

#4 02-12-2019 12:01:59

chti5933
Modérateur
Lieu : WAVRIN Nord
Inscription : 31-10-2017
Messages : 348
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

mothsart a écrit :

C'est dommage pour Shutter. Je ne sais pas ce que vaut Flameshott.

Bonjour,

         je n'ai pas la compétence pour comprendre ce post, par contre je ne connaissait pas Flameshot, et je lui trouve un intérêt certain,

je n'ai testé que la capture partielle d'un écran
autour de la capture apparaît une série d'icône pour gérer la capture très riche, j'adopte à l'essaie

Merci

Pierre


les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!

Hors ligne

#5 02-12-2019 21:26:46

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 982

Re : PrimTux4 pour Raspberry Pi 4ème génération

Philippe Dpt35 a écrit :

Oui, à condition de le faire sur une Raspbian Buster !

Oui, c'était sous-entendu.
Bon, c'est une bonne nouvelle, y'a plus qu'à.

Hors ligne

#6 04-12-2019 10:31:29

Alain
Membre
Inscription : 20-07-2017
Messages : 225

Re : PrimTux4 pour Raspberry Pi 4ème génération

Est ce que ton image s'installe également sur une raspberry 3b ou 3B+ ?

Hors ligne

#7 04-12-2019 13:07:49

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

oui !

Hors ligne

#8 08-12-2019 19:18:18

Alain
Membre
Inscription : 20-07-2017
Messages : 225

Re : PrimTux4 pour Raspberry Pi 4ème génération

Bonjour Philippe
peux tu me donner la marque et le modele de carte que tu utilises en 32 go car je n'ai pas pu transférer l'image avec etcher,
ma carte de 32 go n'était pas suffisante.
Merci
Alain

Hors ligne

#9 08-12-2019 19:38:13

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

J'avais pourtant réduit la taille de la partition de 100 Mo pour éviter ce genre de soucis ! C'est ce que je faisais pour les images 16Go de Raspbian stretch et ça marchait bien. Ce n'est peut-être pas suffisant sur les 32Go.

Un autre utilisateur a réussi l'installation, mais après avoir également dû changer de carte (ça semblait plutôt être un problème de carte défectueuse et non de taille disponible).

J'ai travaillé sur une Sandisk ultra 32 Go.

Hors ligne

#10 08-12-2019 20:01:48

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

P.S.: peux-tu m'indiquer la taille marquée disponible pour ta carte SD. ça me servira pour ajuster la taille de mes images à proposer au téléchargement.

Hors ligne

#11 08-12-2019 21:34:49

Alain
Membre
Inscription : 20-07-2017
Messages : 225

Re : PrimTux4 pour Raspberry Pi 4ème génération

28,64 goctets

Hors ligne

#12 09-12-2019 05:25:40

Philippe Dpt35
Administrateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 3 065
Site Web

Re : PrimTux4 pour Raspberry Pi 4ème génération

Il y a effectivement un gros écart, la taille de l'image étant de 29,72 Go.
Pour les prochaines constructions, je réduirai d'1,5 Go, en recommandant d'étendre ensuite sa partition avec raspi-config après installation.

Hors ligne

Pied de page des forums