La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

Les différentes isos de PrimTux4 sont disponibles, cliquez ici pour choisir votre version.

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Carte des membres pouvant aider et des écoles sous PrimTux, merci de nous envoyer un email si vous souhaitez y apparaître.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#51 17-10-2018 16:08:54

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 374
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Steph a écrit :

Essaie ça pour voir, je corrigerai le paquet tout de suite:

Pour le handymenu là il faudra peut-être renommer (en super-utilisateur) les fichiers /etc/handymenu des rpi en ajoutant .default comme suggéré dans le message du terminal: handymenu-mini.rpi.default.yaml

C'est un correctif à faire dans le script python. Le paquet contient en effet des fichiers handymenu-mini.rpi.default.yaml qui sont renommés handymenu-mini.default.yaml dans le cas où on se trouve sur un RPi.

Le script le fait correctement, mais il y a sans doute une routine qui tente encore de renommer ce fichier alors que ça a déjà été fait, donc il ne le trouve pas.

Hors ligne

#52 17-10-2018 18:20:09

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 597

Re : PrimTux3 pour Rapberry Pi: tests

Ma rpi est encore en train de faire les maj donc je n'ai pas encore le fameux message mais je suis presque sur que c'est l'oubli d'un slash dans mon commit : https://framagit.org/Steph/handymenu-pr … 06807a7fc7

Donc, non : c'est pas lié à un script python mais à un manque d'attention... encore une maj du paquet handymenu à prévoir.
(désolé, Steph)
Dès que c'est lié à ce qui est dans le paquet debian et non à l'applicatif en lui-même j'aurais tendance à incrémenter 1.2.2.1

Hors ligne

#53 09-12-2018 17:46:57

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Adieu a totes,

Un petit retour sur Primtux4 -Debian9-DG-RPi-2018-11-28.img que je suis en train de tester/configurer sur un RaspBerry Pi 3 B+ avant de le déployer dans une classe pour 6 RasPi avec des cartes microSD de 32 Go.
Aucune difficulté d'installation (bon je connaissais plutôt bien avant les Raspberry Pi).
Bien penser à étendre la partition pour utiliser la totalite de la carte SD et à activer l'audio pour prise casque via raspi-config. Peut-être pourrait-il y avoir un raccourci dans le menu "Système" vers cet utilitaire essentiel ?
Cette version est vraiment un plus car un.e utilisateur.rice ne sera pas dépaysé.e quel que soit le type de machine sur lequel est installé Primtux : c'est un gros avantage !

DWService (pour prise à contrôle à distance) que j'ai installé, fonctionne très bien mais en mode terminal (la fenêtre graphique ne s'ouvre pas sinon).

J'ai ces erreurs lors de l'installation de ces appli mais j'ai vu dans les échanges du forum que c'est normal :

Des erreurs ont été rencontrées pendant l'exécution :
 activites-jclic-primtux
 logiciels-primtux-maxi
 logiciels-primtux-mini
 logiciels-primtux-super

Dans LibreOffice, je n'ai pas la barre Svox (mais je pense que ce n'est pas unique à cette version de Primtux, j'ai la même absence sur la version i686-DG) alors que le module PicoSvoxOoOo est bien installé et la synthèse vocale réglée sur fr-FR.

Très satisfait de Chromium comme navigateur d'autant que l'administrateur peut garder ses pages en mémoire pour la réouverture (chose impossible dans la i686-DG avec SeaMonkey ou Firefox).

Les ouvertures d'applications sont assez rapides ce qui rend l'utilisation confortable. Beau boulot !
Je garde une trace de mes tests, installations comme aide-mémoire et pour les partager ici : https://lofurol.fr/joomla/logiciels-lib … erry-pi-3b

Cordialement,

Thierry

Hors ligne

#54 09-12-2018 17:58:34

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 374
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Merci pour ton retour.

ThierryM a écrit :

J'ai ces erreurs lors de l'installation de ces appli mais j'ai vu dans les échanges du forum que c'est normal :

Des erreurs ont été rencontrées pendant l'exécution :
 activites-jclic-primtux
 logiciels-primtux-maxi
 logiciels-primtux-mini
 logiciels-primtux-super

Peux-tu préciser quand tu rencontres cette erreur, car maintenant les logiciels complémentaires sont installables sur le RPi.

Hors ligne

#55 09-12-2018 18:06:30

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

J'ai ces erreurs lorsque j'installe les logiciels non-libres via la page d'accueil. C'est le paquet activites-jclic-primtux qui bloque les autres :

logiciel-primtux-xxxxxx dépend de activites-jclic-primtux cependant le paquet activites-jclic-primtux n'est pas encore configuré.

Cordialement,

Thierry

Voici le message d'erreur complet :

[sudo] Mot de passe de administrateur : 
Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Atteint:2 http://depot.primtux.fr/repo/debs PrimTux-armhf InRelease                                 
Atteint:3 http://archive.raspberrypi.org/debian stretch InRelease                                   
Lecture des listes de paquets... Fait                          
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
logiciels-primtux-maxi is already the newest version (1.1.11).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
4 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Paramétrage de activites-jclic-primtux (1.0) ...
tar (child): /tmp/activites-jclic.tar.gz : open impossible: Aucun fichier ou dossier de ce type
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
dpkg: erreur de traitement du paquet activites-jclic-primtux (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg: des problèmes de dépendances empêchent la configuration de logiciels-primtux-maxi :
 logiciels-primtux-maxi dépend de activites-jclic-primtux ; cependant :
 Le paquet activites-jclic-primtux n'est pas encore configuré.

dpkg: erreur de traitement du paquet logiciels-primtux-maxi (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de logiciels-primtux-mini :
 logiciels-primtux-mini dépend de activites-jclic-primtux ; cependant :
 Le paquet activites-jclic-primtux n'est pas encore configuré.

dpkg: erreur de traitement du paquet logiciels-primtux-mini (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de logiciels-primtux-super :
 logiciels-primtux-super dépend de activites-jclic-primtux ; cependant :
 Le paquet activites-jclic-primtux n'est pas encore configuré.

dpkg: erreur de traitement du paquet logiciels-primtux-super (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 activites-jclic-primtux
 logiciels-primtux-maxi
 logiciels-primtux-mini
 logiciels-primtux-super
E: Sub-process /usr/bin/dpkg returned an error code (1)
Tous les paquets ont été correctement installés.
administrateur@raspberrypi:~$ 

Dernière modification par ThierryM (09-12-2018 18:08:09)

Hors ligne

#56 09-12-2018 18:19:26

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Bon problème résolu après un :

sudo apt remove activites-jclic-primtux

Suivi d'une réinstallation des 4 paquets.

Hors ligne

#57 09-12-2018 18:20:06

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 374
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Tu travailles sur une carte mémoire de quelle taille ?

Hors ligne

#58 09-12-2018 20:27:32

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Sur une 32 Go.

Hors ligne

#59 09-12-2018 20:38:17

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 374
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Donc pas de problème d'installation lié à la taille. Une 16 Go c'est insuffisant pour les logiciels complémentaires.

En revanche il n'est pas normal que tu aies été obligé de supprimer le paquet activités-jclic-primtux. C'est du Java, et ça passe sur RPi en l'état. Je l'avais testé. Il faut donc que je vois pourquoi ça bloque, mais pas avant quelques jours parce que là je n'ai pas accès à mes RPi.

Hors ligne

#60 09-12-2018 20:52:41

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Je pense que lors de l'installation j'ai eu une coupure ou quelque chose comme ça. Je ne pense pas que ça vaille la peine d'investiguer. En l'état, tout à l'air de fonctionner correctement.
Cordialement.

Hors ligne

#61 09-12-2018 22:16:47

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 374
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Tu peux toujours réssayer l'installation du paquet activités-jclic-primtux, soit en ligne de commande, soit par Synaptic.

Hors ligne

#62 09-12-2018 22:31:50

ThierryM
Membre
Lieu : Les Corbières
Inscription : 17-09-2017
Messages : 35
Site Web

Re : PrimTux3 pour Rapberry Pi: tests

Ça y est   wink , mon problème a été résolu (cf post 56 ci-dessus) après suppression avec "sudo apt remove activites-jclic-primtux" et réinstallation avec "sudo apt-get install activites-jclic-primtux logiciels-primtux-*".
Cordialement.

Dernière modification par ThierryM (09-12-2018 22:32:17)

Hors ligne

Pied de page des forums