La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

Les téléchargements sont suspendus jusqu'à envoi de nouvelles versions. Merci de votre patience!

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Carte des membres pouvant aider et des écoles sous PrimTux, merci de nous envoyer un email si vous souhaitez y apparaître.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#76 28-10-2018 07:38:14

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

Pour résumer les correctifs à faire, j'ai noté:

1-
Icônes de mini: trouvé: répertoire default fichier index.theme dans .icons de mini => changer pTux-24 ed en pTux-24 à Inherits=

2-
Le thème fluxbox de l'admin n'est pas le bon non plus, le remplacement de l'init de fluxbox par celui de la 4 corrigera le pb.

3-
J'avais aussi ajouté des thèmes fluxbox: https://framagit.org/Steph/ptx4/tree/ma … box/styles
Ils ne sont pas dans les isos des 2 et 3.

Vois-tu d'autres choses avant que je ne refasse les archives du script de migration ?

Hors ligne

#77 28-10-2018 08:12:28

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

Pour l'instant non.

Hors ligne

#78 28-10-2018 09:08:16

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

J'ai fait les correctifs.

Stéphane, comme tu connais mieux la distribution dans les moindres détails, peux-tu vérifier que la migration se fait correctement maintenant ?

Hors ligne

#79 28-10-2018 10:50:49

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

Je refais une installation propre et je te dis quoi.

Hors ligne

#80 28-10-2018 15:04:34

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

J'ai un répertoire ;mozilla chez l'admin, sûrement une faute de frappe. Sinon ça a l'air bon, bravo!

Hors ligne

#81 28-10-2018 15:15:43

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

Je corrige et je refais l'archive.

Hors ligne

#82 28-10-2018 16:04:24

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

On va pouvoir mettre ça sur sourceforge quand ça sera prêt.

Hors ligne

#83 28-10-2018 16:10:29

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

En ce qui concerne l'accueil armhf: j'ai 2 paquets accueil armhf. Est-ce qu'il y en a un avec CTP et l'autre sans? Ensuite tu avais fait une synthèse ici:

Philippe Dpt35 a écrit :

Voici une synthèse du travail sur les logiciels complémentaires:

Ont été intégrés

jclicpuzzle-primtux,  tbisuite-primtux, activites-jclic-primtux, pepit-primtux, lacourseauxnombres-primtux, scratch2-primtux, iqpuzzle, matou-matheux-primtux, exooos-aleccor-primtux, exercices-free-primtux, exercices-beaunis-primtux, geogebra-classic, primaths-primtux, atlas-houot-primtux, instrumentpoche-primtux , polices-ecole-primtux, appliplanet-primtux, webstrict-primtux, xnview

Ont été intégré en version alternative

photofiltre-primtux est remplacé par photoflare
flash-primtux est remplacé par browser-plugin-gnash
oracle-java8-set-default est remplacé par default-jre
oracle-java8-installer est remplacé par openjdk-8-jre

Ne peuvent être intégrés

jecompte-primtux            --> technologie incompatible
clicmenu-mini-primtux, clicmenu-super-primtux, clicmenu-maxi-primtux   --> des dizaines de logiciels Windows épars non libres
tuxbot-primtux, jelisavecbiba-primtux    --> technologie incompatible
jelisavecbina-primtux        --> sources introuvables

Les développeurs les compileront peut-être dans le futur

Ardora
Le conjugueur-linux

Autres cas

gcompris Qt: présent dans les dépôts mais ne fonctionne pas
libdvdcss2: utilité non pertinente pour RPi


Posent des difficultés à la compilation

kiwix-vikidia-primtux       --> alternative possible et fonctionnelle en version serveur à tester pour d'éventuels conflits
raconte-moi-primtux

Là avec une case à cocher supplémentaire RPI ça peut passer non? Tu sais même s'il y a 4 paquets d'accueil c'est gérable, il suffit de ne pas se mélanger les pinceaux, mais ça va quand même assez vite à corriger.

Hors ligne

#84 28-10-2018 16:49:34

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

Steph a écrit :

En ce qui concerne l'accueil armhf: j'ai 2 paquets accueil armhf. Est-ce qu'il y en a un avec CTP et l'autre sans?

Oui, comme pour les versions PC.

Voici une synthèse du travail sur les logiciels complémentaires:

Mais ça a été fait sur une Raspbian Stretch.
C'est en voulant faire les installations sur la PrimTux2 RPi sous Jessie que j'ai eu un tas de retours de paquets et dépendances manquantes.

Il faudrait donc refaire la vérification de chaque logiciel sous Jessie. Moi, je ne le referai pas compte-tenu du travail demandé et pour pratiquement personne. Ceux qui les veulent vraiment peuvent facilement passer à la PTX4 RPi DG ou CTP, ou sinon tester par eux-mêmes l'installation par Synaptic des paquets qui les intéressent puisqu'ils sont dans les dépôts.

Ceux qui utilisent PrimTux sur RPi, c'est pinuts par rapport à PrimTux sur PC, et ceux qui n'en ont en plus qu'à la version2 c'est pouillème.

Il y a d'autres priorités.

Tu sais même s'il y a 4 paquets d'accueil c'est gérable, il suffit de ne pas se mélanger les pinceaux, mais ça va quand même assez vite à corriger.

Pour la RPi, je suis obligé de repasser derrière ce que tu as fait pour PC, de reprendre l'ensemble des fichiers du paquet et de m'assurer que je n'ai pas oublié les petits détails comme ne pas oublier de changer le nom de certains paquets, d'en enlever ou en rajouter d'autres, d'en changer certains, de corriger les entrées des handymenus qui ne sont pas les mêmes... tout cela disséminé sur plusieurs fichiers.

C'est vraiment galère avec un risque d'erreur considérable compte-tenu du nombre d'éléments à modifier.

Avec la nouvelle version qui est terminée mais que je préfère ne pas te livrer avant d'avoir fait des tests sur chaque version, on a pour chaque fichier tout ce qui peut être à modifier sous les yeux.

Un seul paquet à maintenir, et 1000 fois plus facile pour gérer les différences entre les versions. Y'a pas photo à l'usage !

Hors ligne

#85 28-10-2018 17:00:50

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

Bon ben Ok, de toute façon on n'est pas pressés, là ça fonctionne. La prochaine échéance c'est donc la sortie de PrimTux4-DG-RPi et PrimTux-4-CTP-RPi avec disparition (archivage) des versions 3 (?) .
Si je suis les versions: sous Rpi 3b+, c'est forcément du Jessie? C'est donc voué à disparaître aussi à plus ou moins brève échéance, non?

Hors ligne

#86 28-10-2018 17:17:27

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

Steph a écrit :

Si je suis les versions: sous Rpi 3b+, c'est forcément du Jessie? C'est donc voué à disparaître aussi à plus ou moins brève échéance, non?

Je pense que ton clavier a fourché ! C'est forcément du Stretch.

Donc, oui, Raspbian Jessie est voué à disparaître sous RPi, puisque en revanche Raspbian  Stretch est compatible avec les anciennes versions de RPi.

Hors ligne

#87 28-10-2018 17:24:34

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 833

Re : Migration 2 et 3 vers 4

Non, je n'avais pas vu la double flèche sur le document des versions. Ben ça ne sert plus à rien de s'embêter avec une Jessie alors si Stretch fonctionne sur tous les Rpi. Je dirais même qu'il vaudrait mieux la mettre en archives, non?

Hors ligne

#88 28-10-2018 17:59:39

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 2 319
Site Web

Re : Migration 2 et 3 vers 4

Steph a écrit :

Ben ça ne sert plus à rien de s'embêter avec une Jessie alors si Stretch fonctionne sur tous les Rpi. Je dirais même qu'il vaudrait mieux la mettre en archives, non?

Je suis d'accord.

Hors ligne

#89 28-10-2018 19:01:49

ideefixe
Modérateur
Lieu : Bourges
Inscription : 04-06-2015
Messages : 2 773

Re : Migration 2 et 3 vers 4

La PrimTux2-rpi est archivée  wink

versions-primtux-2.png

Hors ligne

Pied de page des forums