PrimTux

La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

CARTE DES MEMBRES POUVANT AIDER ET DES ÉCOLES SOUS PRIMTUX
Merci de vous y inscrire en nous envoyant un email si vous souhaitez y apparaître.

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#1 23-12-2019 12:21:38

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 893

Un petit scratch3 à compiler

ici: https://gist.github.com/lyshie/0c493930 … ate-deb-sh

Compilé avec succès et fonctionnel directement en français sous ubuntu 18.04.

Hors ligne

#2 24-12-2019 09:11:18

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 133

Re : Un petit scratch3 à compiler

Salut Steph,

As-tu réussi à l'installer ?
Moi, j'ai toujours une erreur. Par contre, je l'ai installé sous Mint sans problème...

Hors ligne

#3 24-12-2019 10:56:16

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 893

Re : Un petit scratch3 à compiler

Sous ptx5 lubuntu oui.

Hors ligne

#4 24-12-2019 11:39:21

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 133

Re : Un petit scratch3 à compiler

Pourtant c'est la "PrimTux5-Lubuntu-18.04-RC.iso" que j'ai installé...
Je refais un essai tout à l'heure.

Hors ligne

#5 24-12-2019 12:12:37

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 893

Re : Un petit scratch3 à compiler

Quelle est l'erreur? J'ai compilé sur une 18.04.3 peut-être est-ce nécessaire...

Sinon le deb que j'ai fait est ici: https://primtux.fr/scratch-desktop_3.6.0_amd64.deb

Hors ligne

#6 24-12-2019 13:36:25

Steph
Administrateur
Inscription : 03-06-2015
Messages : 5 893

Re : Un petit scratch3 à compiler

Hors ligne

#7 24-12-2019 13:47:10

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 133

Re : Un petit scratch3 à compiler

Steph a écrit :

Quelle est l'erreur? J'ai compilé sur une 18.04.3 peut-être est-ce nécessaire...

J'ai une erreur à ce niveau :

[== Undefined ==]
scratch.sh: 37: scratch.sh: /root/node_modules/.bin/electron-installer-debian: not found
gdebi error, file not found: /tmp/scratch-desktop_3.6.0_amd64.deb
root@primtux:/home/administrateur/Documents#

Ce qui correspond à ce que tu m'as envoyé wink et cela fonctionne beaucoup mieux...

EDIT :
Par contre, il serait peut-être intéressant de supprimer certaines versions... ne laisser la version 1.4 pour les vieux PC et la version 3 pour les nouveaux par exemple ou un choix à l'installation. Car on peut avoir les 3 versions d'installer.

Hors ligne

#8 24-12-2019 14:17:32

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 1 109

Re : Un petit scratch3 à compiler

zoom61 : en vue du message, tu as un soucis sur ton install avec "npm" + tu lances ton script en "root".
Normalement, une création de paquet (seul l'installation) ne se fait JAMAIS avec des droits root.

Je dirais que ton soucis provient de là.

Hors ligne

#9 24-12-2019 14:40:47

zoom61
Modérateur
Inscription : 07-09-2015
Messages : 1 133

Re : Un petit scratch3 à compiler

mothsart a écrit :

zoom61 : en vue du message, tu as un soucis sur ton install avec "npm" + tu lances ton script en "root".
Normalement, une création de paquet (seul l'installation) ne se fait JAMAIS avec des droits root.

Je dirais que ton soucis provient de là.

J'avais testé les deux et j'arrivais au même résultat.

Hors ligne

Pied de page des forums