La distribution éducative pour débutants et initiés.

Vous n'êtes pas identifié(e).

Annonce

PrimTux3-Raspberry Pi est disponible pour tests ici

  • Pour être automatiquement informé des réponses à vos messages sur le forum, n'oubliez pas de cliquer sur "Suivre cette discussion" en bas de page. Mieux, en vous abonnant au flux RSS du forum, vous pourrez suivre tout nouveau message sur l'ensemble du forum.
  • En allant dans votre Profil, ligne "Vie privée", vous pouvez également cocher "Suivre automatiquement les sujets auxquels on a répondu.", vous n'aurez plus à cliquer sur "Suivre cette discussion" lorsque vous postez un message.
  • Carte des membres pouvant aider et des écoles sous PrimTux, merci de nous envoyer un email si vous souhaitez y apparaître.
  • Abonnez-vous à la newsletter sur le site principal pour être informé des nouveaux paquets, nouvelles versions, bugs...

#26 04-05-2018 20:06:18

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

C'est vrai qu'avec les commits, puisque tu n'as pas fait de nouvelle version, je vais pouvoir m'y retrouver assez facilement

Hors ligne

#27 05-05-2018 08:14:44

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

Je profite d'un très court passage chez moi avant de repartir pour tester les paquets compilés par mothsart.
Je me suis contenté d'une tentative d'installation et la vérification du bon lancement des applications depuis le menu principal et le handymenu.

Tout est OK sauf openboard pour lequel j'échoue à l'installation avec des dépendances manquantes mais que je ne trouve pas dans les dépôts Raspbian lorsque je cherche à les installer indépendamment (libfdk-aac1). Je n'ai pas le temps d'investiguer davantage aujourd'hui. Je reverrai ça la semaine prochaine.

Voici, à toutes fins utiles, les retours de console:

[== Undefined ==]
Sélection du paquet openboard précédemment désélectionné.
(Lecture de la base de données... 243820 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de openboard_raspbian_9.4_1.4.0_armhf.deb ...
Dépaquetage de openboard (1.4.0) ...
dpkg: des problèmes de dépendances empêchent la configuration de openboard :
 openboard dépend de libfdk-aac1 (>= 0.1.4) ; cependant :
  Le paquet libfdk-aac1 n'est pas installé.
 openboard dépend de onboard ; cependant :
  Le paquet onboard n'est pas installé.
 openboard dépend de libqt5multimedia5-plugins ; cependant :
  Le paquet libqt5multimedia5-plugins n'est pas installé.

dpkg: erreur de traitement du paquet openboard (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Des erreurs ont été rencontrées pendant l'exécution :
 openboard

Par ailleurs, sur letterrier-ALLER et letterrier-imageo on a au lancement des applications un gros pavé

Version de test

au démarrage.
Je crains que cela ne perturbe les utilisateurs. Qu'en pensez-vous ?
Mothsart, as-tu pris les versions marquées stables dans les dépôts ?

Hors ligne

#28 05-05-2018 08:22:39

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

C'est moi qui ne l'ai pas mis dans le dépôt, je corrige.

Hors ligne

#29 05-05-2018 10:18:46

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

Steph a écrit :

C'est moi qui ne l'ai pas mis dans le dépôt, je corrige.

Si c'est du binaire, ça ne passera pas pour le RPi.
Mais mothsart en a forcément eu besoin pour compiler openboard, donc au pire lui a une version arm.

Hors ligne

#30 05-05-2018 10:37:46

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Je parle de la version armhf qu'il a compilée.

Hors ligne

#31 05-05-2018 12:42:05

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 289

Re : PrimTux 3 pour Raspberry Pi - développement

Philippe a écrit :

Par ailleurs, sur letterrier-ALLER et letterrier-imageo on a au lancement des applications un gros pavé

Version de test

au démarrage.
Je crains que cela ne perturbe les utilisateurs. Qu'en pensez-vous ?
Mothsart, as-tu pris les versions marquées stables dans les dépôts ?

Ça m'a surpris également. Je me suis basé sur les branches stables les plus récentes, en effet.
Je peux tester une compile sur une branche inférieur (je communiquerais les numéro de version) et voir ce que ça donne.

Maintenant, si c'est juste une histoire de perturbation de l'utilisateur (alors que le soft est lui fonctionnel : j'ai franchement pas pris le temps de tester au delà d'une partie par curiosité), je peux très bien changer l'image au lancement.

Hors ligne

#32 05-05-2018 13:52:29

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

mothsart a écrit :

je peux très bien changer l'image au lancement.

J'y ai songé. Sa licence nous l'autorise-t-elle?

Hors ligne

#33 05-05-2018 16:25:37

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

C'est maintenant OK pour openboard

Hors ligne

#34 06-05-2018 09:10:49

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 289

Re : PrimTux 3 pour Raspberry Pi - développement

Philippe a écrit :

J'y ai songé. Sa licence nous l'autorise-t-elle?

Hum, j'en sais rien du tout.
Je ne sais pas quel rapports il y a entre PrimTux et AbulEdu ? aucun ? solidaire ? concurrent ?
Si  c'est solidaire, je pourrais leur demander :
- Sur quel version (branche) partir. Si c'est la bonne, est-ce que l'on peut changer facilement l'image.
- leur mentionner l'effort que nous avons fait de porter leur soft sur ARM : ils en seraient bénéficiaires.

Hors ligne

#35 06-05-2018 09:16:15

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Je partirais sur aucun, ils sont plus partis sur des applications que leur distribution qui semble au point mort.
À savoir aussi que là vous utilisez une version plus moderne que celle qu est dans les PrimTux PC.

Hors ligne

#36 06-05-2018 10:07:06

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

ça ne coûte rien de leur demander. Au pire, les choses resteront en l'état, au mieux les modifications et le portage sur arm profiteront à tout le monde !

Hors ligne

#37 10-05-2018 13:45:46

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 289

Re : PrimTux 3 pour Raspberry Pi - développement

Pour connaitre les retours de AbulEdu :

http://forum.abuledu.org/viewtopic.php? … dceb3#p621

Dès que j'aurais terminé mes devs sur les handymenu, je modifierais les images sur  letterrier-ALLER et letterrier-imageo.

Sinon, y'a des correctifs proposés par Xdeladour pour les logiciels du terriers en version Tcl : je ne sais pas si ça peut servir...

Hors ligne

#38 10-05-2018 18:34:36

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

N'étant pas inscrit sur le forum d'Abuledu (et n'ayant pas trop le temps de le faire en ce moment), je réponds ici:

Steph a écrit :

j'ai remplacé $progaide par firefox et ça s'ouvre, mais dans une distribution où firefox n'est pas le programme qui ouvre les html par défaut, cette solution ne fonctionnera pas.

Il suffit d'utiliser comme commande

xdg-open 

comme nom de programme. Cela ouvrira le fichier avec le programme par défaut (ici le navigateur par défaut du système).

Hors ligne

#39 10-05-2018 18:59:07

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Je m'en méfie de cet xdg-open, je l'ai utilisé pour certaines commandes et ça n'a pas eu l'effet escompté, ça n'ouvrait rien malgré des associations correctes. Comme PrimTux est un amalgame de plusieurs gestionnaires graphiques, je pense que ça entre en ligne de compte.

Hors ligne

#40 15-05-2018 14:00:30

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

Je me remets à la construction pour RPi. Il faut que j'intègre tous les changements intervenus sur la PrimTux 3.

Mothsart, as-tu effectué les modifications sur letterrier-ALLER et letterrier-imageo pour supprimer le bandeau de version d'essai, et refait les paquets ?

Hors ligne

#41 15-05-2018 14:03:21

mothsart
Modérateur
Inscription : 31-10-2016
Messages : 289

Re : PrimTux 3 pour Raspberry Pi - développement

Pas encore, mais je viens de recevoir le process par un mec d'AbulEdu :

https://forum.abuledu.org/viewtopic.php … 6df4161383

Hors ligne

#42 15-05-2018 15:39:47

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

mothsart a écrit :

Pas encore, mais je viens de recevoir le process par un mec d'AbulEdu

Il n'y a pas d'urgence, il est préférable que ça soit stabilisé au niveau de la PrimTux 3 PC avant de proposer l'image pour RPi.

Hors ligne

#43 15-05-2018 16:55:09

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

En voulant installer edit-interactive-svg_1.0.rc3_all.deb j'ai une erreur de dépendance manquante pour firefox.
Est-ce que ça ne devrait pas être firefox-esr dans les dépendances du paquet ?

Hors ligne

#44 15-05-2018 17:08:43

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Mets à jour, ça c'est l'ancienne version.

Hors ligne

#45 15-05-2018 17:45:22

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

Steph a écrit :

Mets à jour, ça c'est l'ancienne version.

Pourtant, c'est ce que je viens e récupérer aujourd'hui depuis les sources !

Hors ligne

#46 15-05-2018 17:51:46

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Les sources? et le dépôt?

Hors ligne

#47 15-05-2018 17:53:23

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Ok il n'était pas inclus dans le dépôt rpi, je le mets, dans 2 minutes c'est ok.

Hors ligne

#48 15-05-2018 18:13:20

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

ça avance plus vite que je ne le pensais. J'ai une PrimTux3 avec son nouveau look !
Il me reste quelques paquets à reconstruire (peut-être compiler).

Hors ligne

#49 15-05-2018 18:16:05

Steph
Administrateur
Inscription : 03-06-2015
Messages : 4 212

Re : PrimTux 3 pour Raspberry Pi - développement

Je n'ai surtout pas mis les sources à jour depuis une semaine et ça se voit, j'en remets une dose.

Hors ligne

#50 15-05-2018 19:37:14

Philippe Dpt35
Modérateur
Lieu : Ille-et-Vilaine
Inscription : 28-10-2015
Messages : 1 853
Site Web

Re : PrimTux 3 pour Raspberry Pi - développement

Dis-moi quand tu auras fini la mise à jour. Puisque je dois reconstruire certains paquets, je dois attendre de le faire à partir de sources à jour.

Hors ligne

Pied de page des forums