Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Déployer PrimTux avec Systemeback
#1
http://wiki.primtux.fr/doku.php/deployer_primtux
Répondre
#2
Merci ideefixe et tombeckett
Répondre
#3
bonjour ou bonsoir vu l'heure

ayant une dizaine de pc (avec pour l'instant 4 modeles différents) à installer pour l'école maternelle où est ma fille je voudrais avoir plus de renseignement sur le déploiement de PRIMTUX par disque dur.

la question que je me pose est : peut-on faire la sauvegarde comme indiqué et l'installer sur une machine totalement différente de la première.
Je suis en train de paramétrer un PC LENOVO avec un intel core 2 duo et 2go de RAM et un DELL avec CELERON D et 1G0 de RAM.

sachant que les deux PC sont entièrement différent, peut-on installer la sauvegarde du premier sur le second??????

l'installation des périphériques se fera-t-elle sans problème de l'un à l'autre?????????

merci pour vos réponses
Répondre
#4
Oui, on peut, on n'est pas chez Bill! Les firmwares et pilotes sont déjà inclus et génériques. Si le clone ne fonctionne pas, une nouvelle installation n'ira pas mieux. Ce qui peut arriver c'est que le matériel ne soit pas entièrement supporté et qu'il faille s'adapter (et parfois ça ne marche pas, la faute aux constructeurs qui ne prennent pas la peine de développer des drivers pour linux...). Mais je dirais que ça passe dans 90% des cas, sauf chez les imprimantes, où là il est conseillé de choisir un modèle clairement compatible linux.
Répondre
#5
Bonjour Didier, j'ai actualisé les copies d'écran pour PrimTux2 http://wiki.primtux.fr/doku.php/systemback
Répondre
#6
merci pour vos réponses

maintenant il ne me reste plus qu'a installer et personnaliser le premier PC

vérifier que le tout fonctionne

sauvegarder pour déployer sur les autres

et faire la livraison à l'école

je suis confiant

bonne soirée à vous tous
Répondre
#7
Attention à la configuration de la carte ethernet, lis bien le tuto: son nomchange sur les PC de destination.
Répondre
#8
Steph a écrit :Attention à la configuration de la carte ethernet, lis bien le tuto: son nom change sur les PC de destination.

Le tuto est fait pour PrimTux-Liberté. http://wiki.primtux.fr/doku.php/configurer_reseau
Il faudrait faire des copies d'écran sous PrimTux2 pour montrer le radar vert et où se trouve le paramètre à modifier.
Répondre
#9
Corrigé!
Répondre
#10
L'étape préalable à la copie de PrimTux sur un support externe est la préparation des partitions sur ce support avec l'éditeur de partitions dans le menu système. Cet éditeur se nomme Gparted.

[Image: primtux2:primtux2-administrateur_systeme.jpg]
Répondre
#11
Si j'ai bien compris, pour déployer PrimTux avec Systemback,

il faut installer PrimTux sur un disque source plus petit ou égal au disque cible.

Deux disques durs de 80 Go peuvent avoir une capacité différente : par exemple l'un contiendra 75 Go et l'autre 72 Go.

Si j'installe PrimTux sur le disque qui contient 72 Go et que je copie PrimTux avec Systemback sur le disque qui contient 75 Go,
PrimTux risque de ne pas démarrer.

Est-ce bien cela ?

Dans ce cas, il est préférable d'installer PrimTux sur un disque de 40 ou 60 Go pour déployer sur des disques de 80 Go.
Répondre
#12
En général, 2 disques de taille équivalente dès le départ (80 go dans ton exemple) ne poseront pas de problèmes car ils sont reformatés et leur capacité sera alors égale.
Répondre
#13
J'ai refais les copies d'écran avec un disque source de 40 Go et un disque cible de 60 Go.
http://wiki.primtux.fr/doku.php/systemba...partitions
Répondre
#14
Merci! Big Grin
Répondre
#15
ThierryM a écrit :Adieu a totes,

Je fais un retour ici quant à l'utilisation de Systemback pour dupliquer un disque dur sur des HP dx5150 MT (j'en ai récupéré 18 Wink ). Aucun problème pour cloner un disque dur. C'est au moment où je fais une installation que ça coince.

Aussi bien en démarrant sur un disque dur USB externe qu'en reliant directement le disque dur en interne, j'ai un message d'erreur :
Code :
blk_update_request: i/O error, dev fd0, sector 0
J'ai pu me débarrasser de cette erreur en désactivant le lecteur de disquette dans le BIOS.

Après, le démarrage est très long (contrairement à la première installation classique). Je pense qu'il y a un souci au niveau des UUID des disques/partitions. Du coup, j'ai trouvé ici https://www.debian-fr.org/t/resolu-aie-a...d/75847/11 une solution car le problème venait de la partition swap.
Voilà comment j'ai résolu le problème en faisant cette manip sur le disque qui servira de matrice :
1- Commenter la ligne concernant le swap dans /etc/fstab
2- Supprimer l’identifiant du swap dans /etc/initramfs-tools/conf.d/resume.
3- Regénérer l’initramfs avec update-initramfs -u.
Cela a résolu mon problème.

Cordialement,

Thierry
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)