ATTENTION, MERCI DE NE PAS METTRE À JOUR PRIMTUX7 UBUNTU 20.04 VERS LA 22.04, LES HANDYMENUS NE SONT PAS ENCORE COMPATIBLES!
Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Kill Process Hyperion Ambilight
#1
Bonjour,

J’ai installé Hyperion NG sur les 2 Pi 4B Primtux de mes enfants pour leur mettre un ambilight derrière leur écran.
J’ai réussi à faire un systemctl disabled hyperiond@root qui a désactivé le lancement de Hyperion au démarrage de Primtux. Comme ça, les led ne s’allument pas automatiquement quand on allume Primtux.

Ayant Jeedom sur le même LAN, j’ai déjà fait un On Primtux par une prise connectée que Jeedom met que On et un Off Primtux en envoyant au Pi Primtux en ssh un poweroff puis 15 secondes après un Off prise Pi Primtux.

Mon but est de faire la même chose pour l’ambilight des Pi Primtux.

Sur un groupe Raspberry sur Facebook, on m’a dit qu’il suffit de faire systemctl start hyperiond@root pour démarrer Hyperion. Ca marche bien et mon Jeedom envoie donc ça par ssh au Pi Primtux. Ça lance Hyperion et active les led adressables en fonction de l’écran de Primtux.

Mais voici mon problème: quand je fais le start, après je teste en faisant un systemctl status hyperiond@root et ça me montre un process en cours. Ça c’est normal. Mais normalement, le stop doit l’arrêter mais rien.
Le systemctl stop hyperiond@root n’arrête pas Hyperion. Pourquoi?

J’ai testé des killall, pkill mais rien non plus.

J’ai besoin d’aide pour savoir comment arrêter le programme Hyperion une fois qu’il est lancé pour arrêter quand je veux les led en utilisant Primtux.

Je précise qu’après un reboot Primtux, le processus Hyperion est bien arrêté.

Merci de votre aide
Répondre
#2
Je ne connais aucun des outils que tu utilises.
Mais je commencerais par vérifier si le problème vient de PrimTux ou de Raspberry Pi OS.
Pour cela j'essaierais de voir si ça fonctionne avec Raspberry pi OS desktop.
Répondre
#3
Oui, le systemctl stop hyperiond@root fonctionne avec Raspbian OS. Donc le problème vient de Primtux!
Répondre
#4
Salut
Citation :Mais voici mon problème: quand je fais le start, après je teste en faisant un systemctl status hyperiond@root et ça me montre un process en cours. Ça c’est normal. Mais normalement, le stop doit l’arrêter mais rien.
Le systemctl stop hyperiond@root n’arrête pas Hyperion. Pourquoi?
Tu peux donner les commandes et les retours précis du terminal, qu'on voit ce qu'il raconte
All you need : #!/bin/bash
Répondre
#5
Vous pouvez installer Hyperion sur votre Primtux aussi svp et voir ça?

Voilà ce que ça donne.

[Image: mini_210303072310335592.jpg]
Répondre
#6
Je me renseigne un peu là et ça en fait de la manipulation pour avoir des leds autour de l'écran! T'as pas un interrupteur ? :lol:
Répondre
#7
Bonjour,

J’ai fait de nombreux tests hier et il s’avère que Hyperion ne se laisse pas au boot de Primtux même s’il est sur enable. J’ai donc refait un systemctl enable hyperiond@root.
Après un reboot, j’ai ouvert Hyperion avec un systemctl start hyperiond@root et ca allume les led ambilight et ca les adapte à l’écran! C’est top! Et un systemctl stop hyperiond@root arrête Hyperion et éteint les led ou si j’arrête Primtux ca éteint aussi les led! Donc avec Jeedom, j’ai fait un virtuel On/Off Ambilight en plus du On/Off Primtux et j’ai remonté ca sur Google pour commander Primtux ou l’ambilight! Ça marche au top!
Répondre
#8
Bon ben content que tu t'en sois sorti parce que les ambilight c'est pas trop notre spécialité.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)