Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Tests PrimTux6 RPi
Bonjour
pour pragmatice la synthese vocale ( quand elle est utilisée ) est liée à l'application orthodefi
exemple
https://pragmatice.net/pragmactivites/or...x.html?epe
Alain
Répondre
J'ai regardé et c'est pas réellement de la synthèse vocale mais un fichier son mp3 lu (sans doute créé avec de la synthèse vocale) dans Pramatice.
Donc si t'as une différence entre chrome et Firefox c'est sans doute lié au codec mp3 qui doit être daubé !
Répondre
Bon vu la performance du petit truc et la qualité de l'image j'ai acheté 2 rpi 400 pour ma classe.
Répondre
C'est vrai qu'avec ces nouvelles générations de RPi, ça devient vraiment crédible pour équiper des écoles à moindre coût.
L'enseignant en collège de Rennes qui m'a sollicité pour une aide à l'installation de PrimTux va d'ailleurs équiper sa classe d'EGPA avec des Pi 400 et une moodle box.
Répondre
Faut juste faire attention à 2-3 choses: les kits sont livrés avec une microsd 16 Go et si on a des écrans de récupération, penser à acheter des adaptateurs micro-hdmi => vga.
Répondre
Bon, ben c'est des good news : je pense qu'on a bien fait de mettre beaucoup d'efforts dans une version rpi !
@Steph, ah, les convertisseeurs hdmi => vga (j'inclu micro-hdmi) : je pense qu'il faut y mettre le prix, j'ai eu que des déboires avec ceux que j'ai acheté => durée de vie très courte.
Répondre
@philippe on la lance officiellement?
Répondre
Je pense qu'on peut si tout le monde est OK !
Répondre
Sur la page de téléchargement, il faudra proposer la PrimTux4-rpi-ctp-buster pour les RPi jusqu'aux générations 3, et la PrimTux6-rpi uniquement à partir des générations 4 de RPi.
Répondre
Alors synthèse vocale pourrie sous firefox, un début de résolution:

- Installer mbrola, espeak-ng, mbrola-fr1 et fr4 (pour une voix de femme)
- /etc/speech-dispatcher => ligne 262, remplacer la ligne par: DefaultModule espeak-ng-mbrola-generic
- /etc/speech-dispatcher/modules/espeak-ng-mbrola-generic.conf => lignes 227 et 234: régler la vitesse à 100 est acceptable
- rdv ici https://pragmatice.net/pragmactivites/or...index.html pour tester!
Répondre
Le dépôt contrib n'est pas activé, il y a une raison ou c'est un oubli, parce que sans le contrib on n'a pas mbrola.
Répondre
C'est un oubli !
Répondre
Si on fait une annonce publique, il serait sans doute bon de préciser :

Qu'on a eu un nouveau contributeur : ThierryM (sans compter que Steph a sauté le pas également Cool )

Le fait de travailler sur le passage de certains softs pour la rpi nous a forcé à nous synchroniser avec certains projets open-sources
et à aboutis à plusieurs "issues" (correctifs) et demande de merge de l'équipe :

- https://github.com/xournalpp/xournalpp/i...-747837848
- https://github.com/xournalpp/xournalpp/c...baf323b57a
- https://github.com/OpenBoard-org/OpenBoard/pull/413

Egalement, les correctifs sur certains softs au sein de Primtux commence à gagner en popularité :

gSpeech https://linuxfr.org/news/gspeech-passe-en-0-10 avec une intégration sous AUR (Archlinux) :
https://aur.archlinux.org/packages/gspeech
Mais aussi présent sur la distrib NixOS en stable et unstable : https://repology.org/project/gspeech/versions
(bon, là, c'est principalement moi qui ai fait l'effort)

Je trouve important de souligner ces points qui montre que des projets tel que Primtux permettent de nourrir la qualité, l'avancement d'autres projets satellites.
Répondre
Je rapporte à l'usage au fur et à mesure:
- Scratch3: sur le Rpi4b RAS, sur le Pi400 => erreur au chargement, alors est-ce du à la taille d'affichage, à autre chose, je n'en sais rien, toujours est-il qu'il refuse de créer le projet.
- Il serait judicieux de désactiver le saisie automatique dans chromium (pour l(instant j'efface au fur et à masure des passages): si un élève passe, on lui propose systématiquement les réponses
- Pas de pavé numérique sur le pi400, multiplication station ne fonctionne pas, il ne veut pas de shift + chiffres du haut.
Répondre
Adieu a totes,

Désolé de vous avoir lâchés depuis quelques temps mais pas possible autrement.

Je n'ai pas eu le temps de tester la dernière image Primtux6 Rpi car je travaille encore sur une version de décembre ou janvier... mais que j'ai mise à jour hier mercredi 16/06/2021.
Je vous fais juste un retour (car je me suis cassé longtemps les dents dessus) concernant l'installation de la dernière version Arduino IDE 1.8.15 sur Raspberry Pi 4 sous Primtux6.
En effet, je voudrais aussi que ce Raspi pilote une imprimante 3D d'une école (Anet A8) et j'ai besoin de mettre à jour son firmware (autant tout pouvoir faire avec le même nano-ordinateur).

Pour l'instant, la version ARM 64 ne s'installe pas (multiples erreurs dont une concernant Java), il faut prendre la version ARM 32 Bits (et installation en "sudo") : https://www.arduino.cc/en/software.
Il ne s'agit pas d'un problème spécifique à Primtux6, c'est semble-t-il un problème récurrent : https://forum.arduino.cc/t/arduino-ide-c...ved/620153 (je viens de découvrir ce fil qui confirme le problème). Je fais remonter juste pour éviter que d'autres personnes perdent du temps comme moi.

Cordialement,

Thierry

Edit : page de retour d'expérience de cette installation ici : https://lofurol.fr/joomla/impression-3d/...3d-anet-a8
Répondre
Adieu a totes,

J'ai remarqué que la version Primtux 6 pour Raspberry Pi 4 est une version Arm 32 bits.
Est-il possible que je compile (avec le script fourni par Philippe) une version Arm 64 bits ? J'en ai besoin pour mon projet spécifique de pilotage d'imprimante 3D.
Au passage, j'en profite pour vous signaler l'application BlocksCAD qu'on peut récupérer pour une utilisation hors-ligne qui est un mix entre Scratch et OpenScad.
Cordialement,

Thierry
Répondre
ThierryM a écrit :J'ai remarqué que la version Primtux 6 pour Raspberry Pi 4 est une version Arm 32 bits.
Je me souviens qu'à l'époque où j'ai fait la compilation, la version de Raspbian lite proposée par la fondation était en réalité une 32 bits, je ne sais plus pour quelle raison.
Donc assure-toi bien que la version proposée actuellement en Raspi OS lite est bien une réelle 64 bits.

Il n'y a pas de risque à tester le script sur une 64 bits. Le seul problème auquel tu risques d'être confronté, c'est celui de dépendances manquantes, auquel cas tu auras des messages d''erreurs pour des paquets non installés.

Fais-nous un retour de tes expériences ! Wink
Répondre
Adieu a totes,

En fait, je pensais qu'il existait déjà une version stable de Raspberry Pi OS 64 mais ce n'est pas encore le cas même si le portage/passage est en cours : https://downloads.raspberrypi.org/raspios_arm64/images/ (dernière version du 28/05/2021).
Fil parlant de cette version : https://www.raspberrypi.org/forums/viewt...p?t=275370
Du coup, je ne vais pas me lancer dans cette compilation tant qu'il n'y aura pas de version officielle définitive pour l'architecture 64 bits Wink .
Cordialement,

Thierry
Répondre
Re-Adieu,

Où peut-on récupérer la dernière image Primtux6 pour Raspberry pi 4 afin de la tester (la dernière est toujours celle du 16/02/2021) ?
Merci,

Thierry
Répondre
https://primtux.fr/telecharger-primtux/
Répondre
Merci Steph.
Je pensais qu'il y en avait une autre en test.
@lèu,

Thierry
Répondre
Adieu,

Problème lors de l'installation du contrôle parental avec la version Primtux6 au téléchargement :

Code :
Les paquets suivants ont des dépendances non satisfaites :
plymouth : Est en conflit avec: console-common but 0.7.90+deb10u1 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     console-common [Non installé]                            

     Leave the following dependencies unresolved:              
2)     console-data recommande console-common (>= 0.7.62)      

Accepter cette solution ? [Y/n/q/?]

Cordialement,

Thierry
Répondre
T'as fait Yes?
Répondre
Adieu Steph,

Non, je n'avais pas poursuivi l'installation : j'avais quitté.
Du coup, j'ai relancé l'installation aujourd'hui et accepté le choix par défaut (Y), ce qui a lancé l'installation des paquets. Du coup, il y a eu ce message :
Code :
Les paquets suivant sont RECOMMANDÉS mais ne seront pas installés :
console-common
Tout semble fonctionner.
Remarque : je n'ai pas eu de raccourci créé dans la barre personnelle de Firefox alors qu'il me semble que le raccourci se créait automatiquement (ce n'est pas bien grave, on y arrive par les "Préférences élèves").

Cordialement,

Thierry
Répondre
Pour le raccourci manquant, tu peux le recréer, l'accès se faisant par
https://admin.ct.local
J'ai déjà parfois rencontré ce problème de raccourci qui ne se crée pas sur des PTx6 PC. J'avoue ne pas en avoir recherché la raison, recréer le raccourci étant la solution qui me demandait le moins de perte de temps !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)