Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Tests PrimTux6 RPi
#!/bin/bash

# Debian, Raspbian ou Ubuntu ?
id=$(cat /etc/os-release | grep ^ID= | cut -d"=" -f2)

cd /usr/local/bin/primtux

if [ "$id" = "raspbian" ]
then
mv -f logiciels-mini-arm logiciels-mini
mv -f logiciels-super-arm logiciels-super
mv -f logiciels-maxi-arm logiciels-maxi
mv -f logiciels-outils-arm logiciels-outils
mv -f logiciels-all-arm logiciels-all
fi
exit 0
Répondre
Il faut vérifier si c'est toujours bien raspbian qui est renvoyé vu qu'ils ont changé de nom d'OS (Raspberry pi OS).

J'avais en tête un paquet accueil-primtux mais c'est vrai qu'on change le nom avec accueil-primtux6. Donc oui, ça devrait faire en vérifiant le point précédent.
Répondre
C'est toujours bien raspbian qui est renvoyé.
J'ai vérifié le paquet 0.9.4.4 et il me semble correct. ça devrait marcher.
Place-le dans le dépôt primtux6-armhf, je vais le tester.
Répondre
fait
Répondre
ça a l'air bon.
Il reste Abulédu Mulot sans icône dans les handymenus, mais ça ne dépend pas de ce paquet. Il faut que je vois pourquoi.
Répondre
J'ai refait une image disponible ici :
https://sourceforge.net/projects/primtux...z/download
md5
https://sourceforge.net/projects/primtux...5/download

corrigeant les derniers problèmes évoqués.

Si quelqu'un veut bien la tester pour être sûr qu'elle est opérationnelle avant diffusion publique !
Répondre
le md5 est celui de l'ancienne.
Répondre
Normal, j'avais mis le lien de celle d'avant ! :-{
J'ai corrigé !
Répondre
Md5 ok
Premier demarrage
Session admin avec ethernet
Demande installation controle parental
Au bout de quelques lignes conflit detecte avec un autre processu utilisant apt
Abandon
Je demande l'
install des logiciels non libres idem
Abandon
Je passe en session maxi
Je repasse en session admin
Et là je redemande l'installation du ctp
Ca passe c'est accepté
Sur la lancee je demande installation des logiciels non libres
C'est en cours
Alain
Répondre
L'histoire avec apt je l'aie eue sur l'autre et pas là, peut-être une histoire de processus qui se met en route au démarrage puis s'arrête...
C'est ok, sauf restauration de session firefox par défaut sus admin, non bloquant car on reste avec qwant en accueil. C'est tout pour l'instant.
Répondre
J'ai également déjà rencontré ce conflit avec apt sur des PrimTux6 PC.

Citation :C'est ok, sauf restauration de session firefox par défaut sus admin,

Quelle est précisément la nature du problème ?
Répondre
il dit qu'il a restauré le profil firefox par défaut. Aussi, calculatice n'est pas installé mais il apparaît dans les handymenus sans icônes.
Répondre
Pour calculatice, en reprenant mes notes, je vois que j'ai oublié de refaire un paquet.
J'avais noté "calculatice-primtux --> paquet marqué all, mais dépendances en :i386. Cependant toutes les dépendances existent pour armhf. Il suffirait donc de refaire le paquet en supprimant les :386 des dépendances"
Je vois ça dès que possible.
Répondre
@Steph
Je me souviens d'avoir discuté avec toi d'un paquet pour lequel il y avait des dépendances marquées i386 que tu ne pouvais pas supprimer parce que sinon ça ne passait pas. Etait-ce pour calculatice ?
Répondre
C'est possible, comme j'essaie d'harmoniser au plus possible les paquets, un amd64 a besoin qu'on lui précise de prendre du 32 bits si l'appli l'exige.
Répondre
Bon ben calculatice ne passera pas sous RPi. Il y a en effet un binaire :
/usr/share/clc-linux/calcul@TICE
Il faudrait marquer ce paquet comme i386 et non comme all.
Pour l'entrée de menu incorrecte dans le handymenu, ça devrait pouvoir se corriger par une mise à jour de paquet.
Répondre
Ben on peut faire un i386 qui ne sera que sous le dépôt rpi?
Répondre
Steph a écrit :Ben on peut faire un i386 qui ne sera que sous le dépôt rpi?
Je ne comprends pas ce que tu veux faire : passer un i386 sous une architecture armhf ????
De toute façon, quoiqu'on fasse, ce paquet ne pourra pas fonctionner sous armhf à cause de ce binaire. Il faudrait qu'il soit compilé pour armhf depuis les sources, si elles sont accessibles.
Répondre
Tout est installé ( logiciels supplémentaires et controle parental active )
quelques remarques
par rapport à mon autre version faite il y 15 jours à partir du script où je n'avais pas installé le controle parental, il y a beaucoup plus de plantages
je pense que si on veut utiliser le controle parental il faudra être sur un raspberry4 avec 4go de ram
Une fois le controle activé, il m' est impossible de le desactiver sur mes raspberry 3b et 3b+ car il y a toujours une erreur de dépassement de délai (je pense qu'il faut reparametrer cela dans les parametres php )

Je vois que dans cette version il y a les activites pragamatice
Elles se lancent en local avec le navigateur chromium (c'est un peu lent mais cela m'a permis de voir que la synthese vocale était relativement bonne contrairement à celle qui se lance avec firefox )
Celle de libre office étant bonne...
Question comment avoir la même qualité de synthese vocale dans firefox en imaginant utiliser les activites en ligne ?
Si on arrive à un meilleure qualité est ce que cela ne vaudrait pas la peine d'associer le lancement des pragmactivites avec firefox plutot que chromium ?
Répondre
Il est clair que cette PrimTux6 RPi est destinée au Pi4 et 400.
Pour les générations antérieurs, ça manque vraiment de fluidité. Avec le contrôle parental, c'est même quasiment inutilisable. Il faudra en rester à la PrimTux4 RPi.

Quant à la question des activités pragmatice et firefox, ça n'est pas propre à la version RPi.
Répondre
Tu as mis un serveur sur le rpi? Parce que l'ancienne version de calculatice pourrait passer, il n'y as pas de binaire.
Répondre
Steph a écrit :Tu as mis un serveur sur le rpi?
A part un outil de copie de carte SD, et un autre limitant l'écriture des logs pour la préserver, je n'ai rien ajouté d'autre par rapport à la version PC.
Mais en regardant des notes de 2018 sur la construction de la PrimTux RPi j'avais déjà noté la présence d'un binaire qui empêchait son intégration.
La version serveur sans binaire remonterait à quand ?
Répondre
Je ne sais pas mais il y a quand même pas mal d'exercices.
Répondre
Va voir là: https://www.laclassedemonsieurdeudon.fr/calculatice
Répondre
Pour Pramatice, Alain parle de synthèse vocale : est-ce que c'est un truc spécialement intégré au soft ou ça pourrait être pilotable par gSpeech pour être le plus uniforme possible.

Même constat pour libreoffice qui intègre de mon souvenir une extension qui ne partage pas du tout le code avec gSpeech : il faudrait un jour harmonisé tout ça !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)