ATTENTION, MERCI DE NE PAS METTRE À JOUR PRIMTUX7 UBUNTU 20.04 VERS LA 22.04, LES HANDYMENUS NE SONT PAS ENCORE COMPATIBLES!
Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
primtux5 installation photoflare
#1
Bonjour
je souhaiterai installer ce programme sur une primtux5 debian i386
Il est dans les programmes de primtux 6 debian
est ce possible ?
si oui comment ?
merci
Alain
Répondre
#2
Il n'est pas dans les dépôt stretch, mais buster, ici: https://packages.debian.org/buster/photoflare
Tu peux toujours tester.
Répondre
#3
merci pour ta r éponse mais j'ai des refus d'installation
[Image: aa.png]

et j'ai aussi un echec pour installer
dep: libc6 (>= 2.28) [armel, armhf, i386, mips, mipsel]
j'ai pourtant rajouté deb http://ftp.fr.debian.org/debian buster main à sources.list
Répondre
#4
Je l'avais intégré dans la PrimTux4 RPi sous Stretch, mais pour cela j'avais dû le compiler depuis les sources pour armhf.
Tu peux tenter la compilation.
Répondre
#5
Ajouter les sources de la buster dans la stretch c'est risqué.
Essaie un peu celle-ci: https://launchpad.net/photofiltre-lx/tru..._17.10.deb
Répondre
#6
Steph a écrit :Ajouter les sources de la buster dans la stretch c'est risqué.
Non, il faut tenter de compiler les sources sous stretch.
Le problème c'est que depuis que j'avais compilé sous Raspbian stretch, les bibliothèques nécessaires ont peut-être évolué et certaines ne sont peut-être pas disponibles sous stretch.
Répondre
#7
Ben si c'est risqué, à une mise à jour il va te casser des paquets à coup sûr.
Répondre
#8
@ Steph
merci
J'ai essayé ton lien
le paquet s'est bien installé mais en mettant beaucoup plus de temps que d'habitude ...
j'ai bien l'icone mais même en modifiant les droits d'execution rien ne se passe
Je crois que je vais rester sur pinta que je trouve un peu difficile pour le c2

j'ai retiré la ligne que j'avais ajoutée à sources.list
Répondre
#9
Il veut l'installer sur une primtux5, donc sous stretch. Je ne vois pas pourquoi les mises à jour poseraient problème, puisque photoflare n'est pas dans les dépôts stretch. Il faut bien sûr ne pas ajouter les dépôts Buster.

Par ailleurs, si la dernière version des sources ne passe pas, je vois que les anciennes version sont taguées. Il doit donc être possible de récupérer une version passant sous stretch.
Répondre
#10
En regardant la version que j'avais compilée pour Raspbian stretch, je vois que c'était une 1.5.5
Répondre
#11
Alain a écrit :j'ai pourtant rajouté deb http://ftp.fr.debian.org/debian buster main à sources.list

Philippe Dpt35 a écrit :Il faut bien sûr ne pas ajouter les dépôts Buster.

Ben c'est ce que je disais :duhuh:
Répondre
#12
Allez une petite compile pour la Debian 9, recharge tes dépôts.
Répondre
#13
Bon
j'ai réussi avec photoflare 1.5.5

sudo apt-get install software-properties-common
puis
sudo add-apt-repository ppa:photoflare/photoflare-stable
puis
sudo apt install photoflare
Répondre
#14
Correction j'avais oublié une ligne


sudo apt-get install software-properties-common
puis
sudo add-apt-repository ppa:photoflare/photoflare-stable
puis
sudo apt update
puis
sudo apt install photoflare

solution trouvée sur http://ubuntuhandbook.org/index.php/2020...otofiltre/
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)