Merci de cliquer ici si vous souhaitez vous inscrire sur le forum.

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Problème installation GRUB
#1
Bonsoir.

J'ai téléchargé la dernière version de Primtux 64 bits.

J'ai créé une clé USB bootable pour l'installation.

J'ai paramétré la séquence de boot du bios.

J'ai sélectionné "installer Primtux" lors du boot sur la clé USB. (1)

Le processus d'installation est arrivé à son terme (ou presque).

La toute dernière étape m'affiche qu'il y a un problème de GRUB et que Primtux ne pourra pas se lancer.

Que faire ?

Merci d'avance à la personne qui passera du temps à me répondre.

Local Hero.
Répondre
#2
Complément.

Les étapes de l'installation se succèdent jusqu'à ...

Affichage de la vignette "Merci d'avoir choisi Primtux 5"

La copie des fichiers est presque terminée ...

Installation du système ...

... configuration du matériel ...

... Installation du Paquet de Grub2

Message "Échec de l'installation de GRUB ... Le paquet grub-efi-amd64-signed n'a pas pu être installé dans /target/ ..."
Répondre
#3
Tu peux :
- retenter l'installation
- utiliser un système disposant de BootRepair pour installer/réparer Grub https://doc.ubuntu-fr.org/boot-repair
Répondre
#4
Merci pour cette rapide réponse.
Ayant déjà tenté plusieurs fois l'installation sans succès, je me lance donc pour la deuxième alternative.
Je vous tiens informé du résultat dès que possible, sans doute demain.
En effet ma connexion internet est très lente, il me faut déjà 2 heures pour télécharger boot-repair-disk.
Bonne soirée.
Local Hero.
Répondre
#5
Tu n'es pas obligé d'utiliser un live BootRepair, comme expliqué dans le lien donné.
Tu démarres ton PC avec le live de PrimTux, et tu installes BootRepair comme indiqué dans le paragraphe
1.2 Installer Boot-Repair depuis une session live

ça sera beaucoup plus rapide.
Répondre
#6
Bonjour.
Merci pour les informations.
J'ai testé le live bootrepair avec succès.

J'ai pu installer Primtux. Ça fonctionne très bien.

Bonne journée.
Répondre
#7
Bonjour,
même problème pour moi : problème d'installation du Grub et OS ne pourra pas démarrer en mode auto.
En regardant ce post, j'ai utiliser BootRepair en live. Réparation réussie mais pas de boot possible après redémarrage.
Auriez-vous une autre solution ?
Merci!
Répondre
#8
C'est un PC en UEFI avec un secure boot activé ?
Si oui, commencer par désactiver le secure boot.
Répondre
#9
Ben voyez-vous j'ai le même problème en dual boot avec windows 10 sur 2 ssd différents, et je ne comprends pas d'où ça vient.

Explications:

- PC en UEFI sans secure boot, clé usb etcher, ptx6-20.04 => installation sur disque dur classique => nickel
- Je remplace mon disque dur par un ssd, clé usb ventoy, ptx6-20.04 => échec d'installation de grub, même boot repair n'en veut pas. En analysant le log de boot repair, on voit un pb de montage de la clé => hypothèse: peut-être du à ventoy => je teste actuellement avec une clé etcher...
Répondre
#10
Ce n'est pas impossible que cela soit dû à Ventoy.

Celui-ci peut rendre des résultats inattendus sur certains PC.
J'ai des PC HP pour lesquels mes clés USB Ventoy passent sans problème, alors que pour d'autres, soit je n'ai pas le menu Ventoy, soit je l'ai bien mais ça échoue lorsque je lance les iso PrimTux qui sont dessus.
Répondre
#11
Ça ne passe pas sous etcher non plus.
Répondre
#12
Sinon il reste la solution plus technique de passer en chroot sur la partition Linux depuis un live CD/USB, et d'installer le grub depuis celle-ci.
Répondre
#13
J'ai testé boot repair et rien non plus... Je vais tester une installation ptx5 pour voir. Le contenu de l'iso n'est pas le même. Maintenant quand je n'avais pas de ssd ça passait parfaitement...
Répondre
#14
Bon... La 5 passe nickel, et je ne sais pas où j'ai foiré dans la 6, je sens que ça va me plaire...
Répondre
#15
Voilà, alors pour l'instant, la version uefi ici: https://sourceforge.net/projects/primtux...o/download passe sur de l'uefi et pas sur du legacy.

La version du 11/11 passe en legacy et pas en uefi.

Je m'attelle à avoir la même iso pour les 2 cas, mais pour l'instant il y a toujours moyen d'avoir une version compatible à chaque cas.
Répondre
#16
Voilà, ça devrait passer en legacy Et en UEfi avec cette version: https://sourceforge.net/projects/primtux...o/download
Répondre
#17
En parcourant ce post, je me rends compte que je suis dans un problème similaire

contexte

devant livrer et ou mettre à jour des pc dans une école, j'ai proposé à l'enseignant qui est mon contact de passer son pc de primtux 5 à 6.Ubuntu.20, toujours en double boot avec Primtux 6
Me le remettant un soir pour livraison le lendemain matin, cela était à priori facile.
Première étape
Installation avec PrimTux6-Ubuntu-20.04-2-amd64-2021-02-24,

Message d'erreur grub ne peu être installé
il est tard , je ne cherche pas dans Forum
j'installe PrimTux6-Ubuntu20.04-1-amd64-2020-12-06

installation sans problème, pas de problème avec grub
je reboote , installation des logiciels, complémentaires
reboot , tout va bien, je fais quelques apports supplémentaires etc
mise à jour complète. grub s'est peut être mis à jour, je ne me souviens pas
j'arrête . il est 2 h du matin
je rends le pc à l'instituteur qui m'écrit

"Pour ma par j'ai un petit souci avec mon ordinateur personnel. Lors de sa mise en route, il ne me propose plus le double Boot et démarre directement sous Windows. Je ne peux donc plus accéder à Prim Tux. Y a t-il une manipulation à faire pour retrouver Prim Tux?"

je récupère le pc samedi
j'ai un liveusb sous etcher avec repeardisk( boot repear en live)
je m'inquiète , le parcours des posts précédents me font dire que le résultat n'est pas garantie.

À noter que ce n'est pas ma première expérience d'échec, grub ne veut pas s'installer
mes solutions
sur mon pc en multiboot où linuxmint est mon os par défaut, cela ne me pose pas de problème,
je démarre linux mint, un coup de sudo os-prober sudo update-grub sudo grub-install /dev/sda.
et le tour est joué.
Je n'ai jamais eu de soucis avec ubuntu original quelque soit le bureau...

À vous réflexion et remarques...
MERCI

Pierre
les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!
Répondre
#18
Pour ma part, je ne comprends pas cet acharnement à vouloir garder windows 10 et un linux sur le même PC. Il suffit que windows se mette à jour pour faire sauter le grub (Ubuntu ou PrimTux d'ailleurs). Si on a un PC avec windows 10 (donc assez puissant), on crée une machine virtuelle, c'est bien plus simple.
Ensuite, chaque linux installé va mettre à jour le grub avec son propre répertoire de boot si jamais une mise à jour de grub est faite. D'où le problème: chaque distribution va vouloir être "maîtresse du boot" et va casser l'autre répertoire de boot linux sur lequel il est possible de ne plus pouvoir démarrer.
À l'installation, il y a aussi la partition gpt qui peut être créée ou non (elle existe si windows 10 est installé), il suffit qu'elle ne soit pas réécrite à l'installation pour que ça foire...
Ma conclusion est simple face à toutes ces complications: pas de multiboot, mais des machines virtuelles. C'est d'ailleurs tellement fiable qu'en clonant des machines virtuelles sur des PC en dur ça passe très bien!
Répondre
#19
sur ce post j'avais noté une installation en double boot avec windows10

Steph a écrit :Ben voyez-vous j'ai le même problème en dual boot avec windows 10 sur 2 ssd différents, et je ne comprends pas d'où ça vient.

et il y avait des soucis avec grub, ...
les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!
Répondre
#20
Oui et finalement ça venait de la partition gpt qu'il faut (ou pas je ne m'en souviens pas) réécrire ou sélectionner. J'ai un multiboot win10 / PrimTux pour tester en dur, en production ça n'a à mon sens aucun intérêt.
Répondre
#21
Steph a écrit :Pour ma part, je ne comprends pas cet acharnement à vouloir garder windows 10 et un linux sur le même PC. Il suffit que windows se mette à jour pour faire sauter le grub (Ubuntu ou PrimTux d'ailleurs). Si on a un PC avec windows 10 (donc assez puissant), on crée une machine virtuelle, c'est bien plus simple.
je ne sais pas faire, mon pc n'a que des multiboot linux , et sur le pc de ma défunte épouse relativement ancien ( livré uefi mais avec windows 7 upgradé en windows 10, le multiboot fonctioonne sans problème avec linuxmint.
Le problème de grub , je l'ai précisé sur mon pc est en multiboot pourtant sans Windows.
Il s'agit d'un pc d'un enseignant pour qui j'ai installé en multiboot primtux 5 en multiboot sans problème.

Je ne vois pas improviser une installation en virtuel , alors que je n'y connais rien

Il y a un souci avec le mutiboot et primtux 6
la solution est peut être avec une machine virtuelle, mais pas forcément toujours, entre autre si la machine est ancienne...

Je veux bien apprendre la machine virtuelle , un conseil...


Merci


PIerre
les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!
Répondre
#22
Il y a peut-être un souci multiboot, c'est possible, mais je n'ai ni le temps ni les compétences pour le régler, surtout qu'il y a dans ce cas précis énormément de problèmes potentiels.
Le boot uefi s'était déréglé en passant d'ubuntu 20.04-1 à 20.04-2 par une mise à jour de grub... Il allait chercher un grub incompatible 20.04-1 qui ne voulait donc pas s'installer, raison pour laquelle il a fallu passer l'iso en 20.04-2.
Pour la création d'une VM, Philippe avait écrit un article très complet sur le wiki:
https://wiki.primtux.fr/doku.php/vm-linux-new
Répondre
#23
Steph a écrit :Il y a peut-être un souci multiboot, c'est possible, mais je n'ai ni le temps ni les compétences pour le régler, surtout qu'il y a dans ce cas précis énormément de problèmes potentiels.
Le boot uefi s'était déréglé en passant d'ubuntu 20.04-1 à 20.04-2 par une mise à jour de grub... Il allait chercher un grub incompatible 20.04-1 qui ne voulait donc pas s'installer, raison pour laquelle il a fallu passer l'iso en 20.04-2.
Pour la création d'une VM, Philippe avait écrit un article très complet sur le wiki:
https://wiki.primtux.fr/doku.php/vm-linux-new

je viens de parcourir la documentation de Philippe avant de l'imposer à un pc d'une tierce personne, il faut que je comprenne, je vais essayer sur mon liniux mint de travail.

Pour le pc de l'enseignant pour lequel le souci a du apparaitre à la mise à jour de 20.04-1, je vais essayer de m'en sortir avec bootrepair.
Sans quoi devant restituer le pc dans la journée, je recommencerai une installation complète mais ne ferai pas de mise à jour...ou comment bloquer mise à jour de grub et faire les autres mise à jour???

Je me vois mal " bidouiller en vitesse " une installation avec virtualbox que je ne connais pas. sur un pc peut être pas assez puissant.
les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!
Répondre
#24
Une fois que c'est installé c'est bon, c'est juste à l'installation que ça foire avec la 20.04-1. Si bootrepair fait le boulot après ça devrait aller.
Répondre
#25
Steph a écrit :Une fois que c'est installé c'est bon, c'est juste à l'installation que ça foire avec la 20.04-1. Si bootrepair fait le boulot après ça devrait aller.

je reprends mon post
chti5933 a écrit :Installation avec PrimTux6-Ubuntu-20.04-2-amd64-2021-02-24,

Message d'erreur grub ne peu être installé
il est tard , je ne cherche pas dans Forum
j'installe PrimTux6-Ubuntu20.04-1-amd64-2020-12-06

installation sans problème, pas de problème avec grub
je reboote , installation des logiciels, complémentaires
reboot , tout va bien, je fais quelques apports supplémentaires etc
mise à jour complète. grub s'est peut être mis à jour, je ne me souviens pas

l'instal, dans mon cas n'a pas foiré avec 20.04-1, c'est ce que j'utilise en multiboot avec linux mint avec les mises à jour,
mais avec la 20.04-2

de toute façon je vais essayer en premier boot repair

je me suis lancé dans virtual box sur ma linux mint, installation avec un souci la commande proposé par Philippe ( dkpi -i) a foiré( problème de dépendance, paquet cassé ... ), finalement le dépôt linux mint le propose et cela fonctionne. Par contre je bloque à l'instal de primtux

je vais poser le problème par ailleurs ( forum ubuntu , ou linux mint ou ...)

quand j'arrive là , je ne trouve pas la commande installer
[Image: 210430065152149914.jpg]

en live, cela occupe qu'une petite partie fde l'écran, c'est peut être normal, je découvre

quant à aller sur un pc qui n'est pas le mien dans win 10... je ne suis pas assez compétent...

Merci Steph
les talents acquis ne nous appartiennent pas, ne les enterreront pas, faisons les fructifier par le partage!
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)